
Using Help

Help is designed to help you get fast results without having to read through a lot of instructions.

The relatively small help window will "stay on top" while you follow the instructions, rather than disappearing like a 
normal help window.    This allows you to check the instructions without having to find your place again.

If the help window is in the way, minimize it rather than closing it.    By minimizing, the window will re-open to the 
same place in the instructions when you restore the window size later.

If the window is in the way, but you don't want to minimize or close it, you can also drag it to another location or shove
it mostly off the side or bottom of the screen.    (To drag it, hold the left mouse button down on the title bar and drag.)   
As long as the title bar is visible you can drag it back at any time.

If your video monitor is set at a relatively low resolution, you may not see much of the help menus at a time.    In this 
case, you can maximize the window for a better view, then restore it to the normal smaller size.    You can also re-
size the window by dragging its border or borders.

If you are not familiar with the terms minimize, restore, maximize, re-size or drag, or how to use a mouse, we 
recommend that you view the Windows Tutorial or get some other instruction in the basics of Windows operation.



Section Menu

The Section Menu is on the Main Menu Bar when the Project Window is active.



Overview

SpecLink is an interactive, "knowledge-based" specification writing system that manages specifications on a project 
basis, rather than a section-by-section basis.    Within each project, all sections are intelligently linked by the software 
so that omissions and contradictions are reduced.

To prepare a project specification, the user first selects a project or starts a new project.    From the project window, 
which shows the table of contents, the user can see at a glance which sections have been included in the project.    At
this point, the user can select additional sections to be included in the project or can "collapse" the table of contents 
to exclude all unselected sections.      

By double clicking on a section number or title, the selected section is opened for detailed editing.    The master text 
can be scrolled and viewed like any document, but it does not look like a document in a normal word processing 
environment.    Each paragraph is in a cell, similar to a spreadsheet, except that the text cell occupies most of the 
screen width.    The text hierarchy for each paragraph occupies a cell at the left edge of the screen.    The current 
status of each paragraph is displayed as well, indicating whether it will be printed in the final document or not.

The status of each paragraph is visually displayed using colors.
All unselected text is on a gray background, while active, selected text which    will print in the project is on a white 
background.

text that the user has selected is marked with an X;
text that has been selected by the system is marked with a green box; 
text that is suggested as relevant by the system is marked with a yellow box. 
text that has been excluded by the system is marked with a red box; 
text that the user has excluded has half the status box blacked out.

Unlike documents in a word processing environment, SpecLink sections and projects feature "intelligent text."    In 
order to create an edited document, the user selects text, rather than deleting it.    As the user makes text selections, 
the program automatically makes other changes to the section and to other sections in the project.    Only valid active 
text, selected by the user or included automatically by the program, will be assembled into the final output.    To be 
active, selected text must have an unbroken line of parentage back to the section title.    This means that any 
"orphaned" text will not be part of the final printed document.



Linking Basics

Within SpecLink, a given paragraph may be linked to any number of other paragraphs both within the section and in 
other sections.    Only one link may exist from any source paragraph to a given target paragraph, but any paragraph 
may be the target of any number of links from multiple source paragraphs.    Also, the links act in one direction only 
and do not result in reciprocal linkage.    For example, a paragraph that automatically selects another paragraph will 
not be selected automatically if the target selection is chosen first;    a separate link acting in the opposite direction 
would be necessary.    In addition, the target paragraph may act on the first paragraph in a different way altogether, or 
not at all.

Text can be viewed and selected in any order, but certain strategies will be more effective than others in taking 
advantage of the intelligence built into the database for each section.    The best order is to start with Part 2 - 
Products, then move to Part 3 - Execution, and finally to Part 1 - General.    The reason for encouraging this order of 
selection is that Part 2 paragraphs, which deal with products and fabrication, will always have more definitive links to 
text in Parts 1 and 3 than either of those parts will have to text in Part 2.

The types of links available between paragraphs within SpecLink and the corresponding text status of each are as 
follows:

Yes Selected

No Excluded

Maybe Pertinent

Combinations of links and user actions result in combination indicators, like , 

, 
, 
, 
, and 
.

Because a given target paragraph may be acted upon by several links of different types (from a number of source 
paragraphs), the text status and related display modes are governed by a hierarchy of consequences, which 
functions in this fashion:

1. Any text may be selected manually at any time, which over-rides any links.

2. Any text may be excluded manually at any time, which also over-rides any links.

3. If not selected or excluded manually but acted upon by one or more links of the same type, the status will 
correspond to that associated with the link type (Yes, No, or Maybe). 

4. If not selected or excluded manually but acted upon by more than one type of link, text status will be determined 
by the following hierarchy, from most to least controlling:    No, Yes, Maybe.

5. If not selected, excluded, or acted upon by any links, the text will be available for selection by the user.

In addition to the obvious links described above, a single No link will override any number of Yes or Maybe links and 
a single Yes link will override any number of Maybe links.    Also, because status of a particular paragraph is 
dependent upon the net effect of all currently active links, removal of a particular link by deselection of the source text
may result in a change in the status of the target paragraph.    The software calculates the current status of each 
paragraph after each change in status of any paragraph and displays the active paragraphs on a white background 
for ease of identification. There are several specific types of links that provide intelligence:

Within each specification section:

1. Product specification text in Part 2 makes Yes links to appropriate installation requirements in Part 3 and relevant
Part 1 requirements, such as submittals and quality assurance provisions.

2. Mutually exclusive choices among products or installation methods each have No links to the other options, so 
that selection of any one of them will automatically exclude the others.

3. Selection of text which contains a reference to a reference standard citation in Part 1 makes a Yes link to the 
reference citation.

Within a project:

1. Each cross-reference within a section makes a Maybe link to the referenced section on the project Table of 



Contents.

2. Each paragraph that refers to requirements in another section makes the appropriate links to change the status 
of paragraphs in the related section. 

3. The Table of Contents for the project is updated automatically as sections are completed, including page counts.



Key Features

Other features of SpecLink include the following:

1. Context-sensitive notes in every section, designed to help users make appropriate text selections, with the option
for project-specific notes added by the    user.

2. Automatic replacement of key terms (owner, design professional, contractor), automatic selection of English or 
metric units, and Yes/No options for inclusion of Related Sections and References articles, with settings saved 
for each project.

3. Project management and reporting for administrative requirements.    The user can preselect text within the 
individual sections from the project window.    By pointing and clicking on status boxes on each section row, text 
that might be affected by project "global" decisions, such as submittals, quality assurance provisions, warranties, 
field testing, etc. (11 different topics), can be included.    Standard reports summarize these provisions for the 
project.

 4. Printable Table of Contents, automatically generated, with optional page count for each section.    

 5. Automated page formatting and printing.    Page formatting functions include three standard, customizable 
paragraph numbering schemes, complete control of margins, customizable headers and footers with key words, 
different fonts at different levels, one- or two-column printing, line numbering.    All documents can be previewed 
prior to printing.

6. "Office Master Project":    Using the SpecLink master database, any office can create a master project containing 
any and all changes deemed necessary or desirable, as well as any pre-selections of sections or text that are 
useful.    This project can then be copied to a new project for further selection of text and editing, eliminating the 
need to copy preferred text to each new project and allowing a great efficiency of text selection for similar 
projects.

7. Updating: A key feature of SpecLink is that changes made in the project do not affect the master database.    
Each project file is an "overlay" containing all changes and current status, which uses the master database each 
time the project is opened.    When the master database is updated, all the original master text is retained in the 
database, so that it continues to be available for projects for which it is desired.    Existing projects are not 
affected by updates unless the user specifically elects to incorporate them.    Updates can be globally or 
selectively incorporated, and project-customized text is not lost even if the master updates are accepted. 



Quick Start

The basic steps to producing a project specification are as follows:

1. Start a new project or open an existing project.

2. Select sections to be included in the project.

3. Open each section and select the text to be included.    Review the notes and links, if necessary, for information 
on the section text.

4. Add text as required.    Add sections not included in Table of Contents using the New Section function.

5. Review the Table of Contents for sections automatically included by links made by other sections -- marked with 
yellow in status box.

6. Review each section for text automatically included by other sections -- marked with green status box without an 
X.    Confirm the appropriateness of added text.

7. When all sections are complete, set up page format and preview.

8. Print sections.



MASTERFORMAT Divisions

Documents 0 Introductory Information, Bidding Requirements, and Contract Requirements
Division 1 General Requirements
Division 2 Site Construction
Division 3 Concrete
Division 4 Masonry
Division 5 Metals
Division 6 Wood and Plastics
Division 7 Thermal and Moisture Protection
Division 8 Doors and Windows
Division 9 Finishes
Division 10 Specialties
Division 11 Equipment
Division 12 Furnishings
Division 13 Special Construction
Division 14 Conveying Systems
Division 15 Mechanical
Division 16 Electrical

MASTERFORMAT © 1995, Construction Specifications Institute



Catalogs

Each section is part of one or more "Catalogs" available by subscription, with the exception of proprietary sections 
which are available without any subscription.    Proprietary sections are marked with a checkmark in the far left-hand 
column of the Project Window.

The Catalogs available to subscribers are:

Architectural -- Divisions 0 through 12, part of Division 13, Division 14, and some sections in Divisions 15 and 16.

Structural -- Divisions 0 and 1, part of Division 2, most of Divisions 3 and 5, part of Divisions 4 and 6, and some 
sections in Divisions 7 and 13.

Civil -- Divisions 0 and 1, Division 2, and some sections in Divisions 3, 4, 5, 7, 9, 13, 15, and 16.

Mechanical/Electrical -- Divisions 0 and 1, part of Division 2, some sections in Divisions 3, 6, 7, 9, and 10, most of 
Division 13, and Divisions 15 and 16.

At the Project Window the Catalogs each section is available in are displayed in an optional status column to the left 
of the section title.    To display the Catalogs, pull down the View Menu, select Status Columns, and then select 
Catalogs.



Three-Part Section Format

All sections are organized according to the Construction Specification Institute's Three-Part Section Format.    The 
Articles in each PART vary from section to section, based on the content of the section.    Listed below are the Article 
titles used when appropriate.    The PARTs are always used.    The Articles marked with an asterisk * are almost 
always used.

PART 1 GENERAL
SECTION INCLUDES*
RELATED SECTIONS*
ALLOWANCES
UNIT PRICES
ALTERNATES/ALTERNATIVES
REFERENCES*
DEFINITIONS
SYSTEM DESCRIPTION
PERFORMANCE REQUIREMENTS
SUBMITTALS*
QUALITY ASSURANCE*
MOCK-UPS
PRE-INSTALLATION MEETINGS
DELIVERY, STORAGE, AND HANDLING
PROJECT CONDITIONS
ENVIRONMENTAL REQUIREMENTS
WARRANTY
EXTRA MATERIALS
MAINTENANCE SERVICE

PART 2 PRODUCTS
MANUFACTURERS*
MATERIALS*
ACCESSORIES*
MIXES
FABRICATION
FINISHING
SOURCE QUALITY CONTROL

PART 3 EXECUTION
EXAMINATION*
PREPARATION*
INSTALLATION*/APPLICATION/ERECTION
INTERFACE WITH OTHER WORK
ERECTION TOLERANCES
FIELD QUALITY CONTROL
STARTING OF EQUIPMENT AND SYSTEMS
ADJUSTING
CLEANING AND PROTECTION
SCHEDULES



Project Requirements Topics

Certain provisions commonly appear in many different specification sections: 

Product Data Submittals.  Manufacturers' catalog data, not prepared specifically for the project.    Appears in PART 
1, SUBMITTALS.

Shop Drawings.    Drawings prepared specifically for the project, to complete the design or to illustrate details left up 
to the Contractor.    Appears in PART 1, SUBMITTALS.

Samples.    Actual products to be furnished, for approval of colors, finishes, etc.    Not used for testing purposes or for 
evaluation of performance.    Appears in PART 1, SUBMITTALS.

Professional Engineer Design.      If major components are commonly designed by an engineer other than the 
engineer-of-record, the section may include that as an option.    If so, the actual requirements will depend on the 
products involved.    e.g. Aluminum curtain wall, major skylights, pre-engineered buildings, etc.    Appears in PART 1, 
QUALITY ASSURANCE.

Pre-installation Meeting.    A special meeting, usually specified with particular attendees and topics to be covered.    
Appears in PART 1, PRE-INSTALLATION MEETING.

Manufacturer Qualifications.  This include "fabricators" if the product is more likely to be shop-fabricated than 
factory-made.    Appears in PART 1, QUALITY ASSURANCE. 

Installer Qualifications.    This includes "applicators" and other similar functions.    Appears in PART 1, QUALITY 
ASSURANCE.

Mock-Up.    A mock-up built during construction for evaluation of workmanship or performance.    Mock-ups for testing 
prior to approval of products are not included in this category.    Another term for this is "field sample" when that refers
to a full-scale portion of the work evaluated in place.    Appears in PART 1, MOCK-UP.

Special Warranty Provisions.    Any warranty provision that involves a term longer than one year or entities other 
than the (prime) Contractor or and the Owner.    The actual terms vary according to the type of product involved.    
Appears in PART 1, WARRANTY.

Extra Materials.    Additional quantities of the materials installed, usually furnished for maintenance purposes.    
Usually limited to products which would be hard to match or acquire in the future.    Appears in PART 1, EXTRA 
MATERIALS.

Independent Agency Field Testing.  Provisions requiring a testing or inspection laboratory or agency to test or 
inspect the work in place.    The section may require the agency to be hired by either the Owner or the Contractor and
the testing will vary according to the type of product involved.    Appears in PART 3, FIELD QUALITY CONTROL.

See Also:    Selecting project requirements from the Project Window



Link Details

Each paragraph and each choice in a paragraph can have a link to any other paragraph or choice.    Each link has a 
Source and a Target.    The Source is the paragraph which must be selected for the link to take effect.    The Target is 
the paragraph whose status is affected by the link.

The links for any paragraph can be viewed at any time by opening the Option Panel.

For both Targets and Sources, the Option Panel shows the following information:

· The "influence":    The type of link. 
· The section number and sequence number of the paragraph affected (target) or influencing (source).
· The text of the paragraph affected/influencing.

All links are displayed, regardless of whether they are in effect or not.    The section and sequence number of those 
that are in effect are displayed in BOLD type to distinguish them from those that are only "potential" links.

The type of link is displayed visually:    Link Targets, Link Sources.    Also, links built into the master database and 
those in the project can be "turned off" if desired.    In some cases, this speeds up the display of links when the links 
panel is open.    Pull down the Tools Menu in the Project Window and uncheck either type of link at Show Master 
Links or Show Project Links.



Link Targets

For Targets, there are the following types of influences:

This paragraph selects the target.
This paragraph recommends the target.
This paragraph excludes the target.
This paragraph toggles on a choice in the target.
A choice in this paragraph selects the target.
A choice in this paragraph recommends the target.
A choice in this paragraph excludes the target.
A choice in this paragraph toggles on a choice in the target.

For paragraphs that are active, all targets are in effect (displayed in bold type).
For paragraphs that are inactive, no targets are in effect (all are potential).



Link Sources

For Sources, there are the following indications of influences:

This paragraph has been selected by the source.
This paragraph has been recommended by the source.
This paragraph has been excluded by the source.
This paragraph has been selected by a choice in the source.
This paragraph has been recommended by a choice in the source.
This paragraph has been excluded by a choice in the source.
A choice in this paragraph has been toggled on by the source.
A choice in this paragraph has been toggled on by a choice in the source.

For paragraphs that have been selected recommended or excluded by the software, at least one source is in effect 
(shown in bold type).
For paragraphs whose status box is still neutral , no sources will be active.



Paragraph Numbering Schemes

Paragraph format setup involves:

1. Selection of the general paragraph numbering scheme from the standard schemes available.

Choose from the three standard numbering schemes available:

CSI style
Military style
Block style

2. Modification of the layout or numbering if necessary.

Layout options that can be modified include the amount of indentation, hanging indents, spacing between 
paragraph numbers and text, punctuation of paragraph numbers, line spacing, and forcing of upper case.

Each time a scheme is modified it is saved in the current project as the "user-defined scheme".    Either a standard 
scheme or the user-defined scheme can then be used for printing.



CSI style paragraph numbering

SECTION 00000 (Level 0) {centered}
{skipped line}

SECTION TITLE (Level 0)    {centered}
{skipped line}
PART 1    GENERAL (Level 1)
{skipped line}
1.01 ARTICLE TITLES (Level 2)
{skipped line}

A. Text of the first paragraph. (Level 3)
1. Text of the first subparagraph. (Level 4)
2. Text of the second subparagraph.

a. Text of the first subparagraph. (Level 5)
1) Text of the first sub-subparagraph. (Level 6)

{skipped line}
B. Text of the second paragraph.

etc.

END OF SECTION (Level 0)    {centered}
 
Level 2 numbers always start with the PART number; i.e. 1, 2, or 3.

This format is called CSI style because it is the format recommended by the Manual of Practice of the Construction 
Specifications Institute.



Military style paragraph numbering

SECTION 00000 (Level 0) {centered}
{skipped line}

SECTION TITLE (Level 0)    {centered}
{skipped line}
PART 1    GENERAL (Level 1)
{skipped line}
1.1 ARTICLE TITLES (Level 2)
{skipped line}
1.1.1 Text of the first paragraph. (Level 3)

a. Text of the first subparagraph. (Level 4)
b. Text of the second subparagraph.

(1) Text of the first subparagraph. (Level 5)
(a) Text of the first sub-subparagraph. (Level 6)

{skipped line}
1.1.2 Text of the second paragraph.

etc.

END OF SECTION (Level 0)    {centered}
 
Level 2 and 3 numbers always start with the PART number; i.e. 1, 2, or 3.

This format is called military style because it conforms as closely as possible to the format used for US Corps of 
Engineers and NAVFAC specifications in the Specs-In-Tact program. 



Block style paragraph format

SECTION 00000 - SECTION TITLE (Level 0)
{skipped line}
PART 1    GENERAL (Level 1)
{skipped line}
ARTICLE TITLES (Level 2)
{skipped line}

Text of the first paragraph. (Level 3)
{skipped line}

Text of the first subparagraph. (Level 4)
{skipped line}

Text of the second subparagraph.
{skipped line}

Text of the first subparagraph. (Level 5)
{skipped line}

Text of the first sub-subparagraph. (Level 6)
{skipped line}

Text of the second paragraph.

etc.

END OF SECTION (Level 0)
 
All paragraphs are double-spaced.

Note:    The line numbering option may be desirable, to identify specific paragraphs for addendum purposes.



Header and Footer Defaults

A different header and footer can be defined for each of the three types of documents that can be printed:    the 
Specification, the Requirements Reports, and the Table of Contents.

Each header and footer is formatted with 3 available lines in 3 horizontal sections:    Left, Center, and Right.
"Keywords" are used to insert the project number, project name, section number, page number, etc., automatically.

Header/Footer Keywords 

Specification header
Specification footer

Requirements reports header
Requirements reports footer

Table of Contents header
Table of Contents footer

Headers and footers can be made to alternate left and right, for two-sided printing:    See Page
Layout.



Header/Footer Keywords

Keywords insert the appropriate words or numbers into the header/footer whenever the document is printed.    For 
some keywords, like the Project Name, the inserted words are obtained from the information recorded under 
Summary Info, and do not change from section to section.    Other keywords change depending on which section is 
being printed, such as the Section ID (CSI number) and the Section Title.
Keywords are surrounded by curly brackets { }.    Any other text can also be entered, provided it does not interfere 
with the bracketed keywords.

Section ID:    The CSI section number.    For master sections this cannot be changed.
Section Title:    The title as it appears in the section.
Project Name:    Entered under Summary Info.
Project ID:    Entered under Summary Info.    Does not have to be the same as the file name.
Design Professional:    Entered under Summary Info.
Owner: Entered under Summary Info.
Contractor: Entered under Summary Info.
Location: Entered under Summary Info.
Page Number:    Starts at 1 for each new section, incremented by 1.
Date:    Today's date, from computer clock.
Time:    From computer clock.
UOM:    The current Units of Measurement setting, from Summary Info.



Printing the Table of Contents

The printed Table of Contents includes all active sections in the project, with the number of pages in each section.

TABLE OF CONTENTS {centered}
{skipped line}
DIVISION 2 - SITE CONSTRUCTION
{skipped line}
02221 BUILDING DEMOLITION ............................................ 4 {left and right justified}
03300 CONCRETE ............................................................... 10
{skipped line between each division}

END OF TABLE OF CONTENTS {centered}

See Also: Table of Contents Header
Table of Contents Footer
Editing the Table of Contents



Printing Requirements Reports

No paragraph numbering is involved when printing reports.    Otherwise, the same page setup options apply as for the
specification.    In addition, a separate header and footer can be defined for reports.

Report Header
Report Footer

See Also:    Page Setup



RTF Format

RTF stands for "Rich Text Format," which is a generic word processing format that is readable by most modern 
Windows-based word processors.

No headers or footers are exported, as it is expected that the word processor's page layout functions would be used.

Some word processors that convert RTF:
Microsoft Word
WordPerfect for Windows 6.0+

Some word processors that don't read RTF directly:
WordPerfect 5.1



Office Master Project

To make preparation of project specifications even more efficient, you can create a master project containing any and
all changes deemed necessary or desirable for the type of projects normally encountered.    These "pre-edits" can 
consist of pre-selections of sections or text that are commonly used as well as preferred language.

A master project is actually simply a normal project, saved and kept aside for this purpose.    In fact, any project can 
be used in this manner -- whether it would be useful depends on how similar it is to the new project.    More than one 
master project could be developed, for different building types, different owners, or different code jurisdictions.

Developing a master project can be a deliberate effort or it can be done piece-meal over time.    An office that has a 
resident specification specialist may decide to devote time to developing a master project or projects, because it will 
save the project teams time and reduce errors.

See Tactics for developing office masters

Others may find that a deliberate effort is not possible, due to time or other constraints, but can still build up a master 
project rather than simply re-using previous projects.    This means making a note of sections done in projects that are
representative of the type of project a master is desired for and copying those sections to a master project made for 
the purpose.    A review of the section at the time it is copied into the master project, keeping in mind the tactics 
suggested, can make it into an even more representative section than it was.

See Also: Types of master projects
Using office master project as new project setup file
Updating projects to a new master
Office standard page format and printing setup



Tactics for developing office masters

See Also:    Importing Text from Clipboard, Adding Links to Project, User-Added Choices, Adding References

Suggested tactics for developing a master project:

1. Decide what the scope will need to be:    building type, location criteria, size, etc.

2. Start a new project, with a name that makes it easily identifiable as a master project.

3. Select the sections that are normally used on such a project.    Don't select every section that might be used -- all 
other sections will be available for use on a real project.

4. In each section selected, select the product options that would be used on most of these projects.    Again, don't 
select everything, just what is most common.    Select appropriate paragraphs and choose the preferred option 
for choices embedded in paragraphs.

5. In each section, select PART 1 and PART 3 provisions to the level of completeness that you normally specify on 
projects of this type.    For instance, if this is a small project master, you may not normally include the full range of
Quality Assurance provisions that are available -- if so, don't select those paragraphs.

6. Exclude paragraphs that involve products or procedures that you never want to use (or want no one else to use) 
on projects.    (A "blocked out" status box by a paragraph in a newly started section will soon become a "flag" 
indicating a policy decision prohibiting its use.)

6. If there are language changes needed or additional provisions that are very common, make them.    Also, 
additional provisions can be added WITHOUT SELECTING THEM, making it possible to create options for lower 
probability occurrences without having them automatically included in new projects.

7. Finally, make notes in the section to yourself or project team members that explain office procedures and policy 
relating to specific paragraphs, product usage or limitations, or explanations of added provisions.    The notes you
add will be marked with a blue icon for easy identification.    If you need to make notes at a paragraph that 
already has a note, just edit that note -- its icon will turn magenta to indicate that it has been edited.



Types of master projects

The most common type of master project will be one based on a single building type, such as a high-rise office 
building, a hospital, a parking garage.

Some other types of master projects that might be prepared:

1. Master projects containing only a few sections for highly specialized work.      In this case, the master project is 
not used to start a new project, but instead its sections are copied to the project desired.

2 Master projects containing only one section, edited for a particular manufacturer's products.    Especially useful 
would be sections that are highly dependent on brand name product specifications, such as paint, door 
hardware, or high performance products of any type.

3. The entire master edited for a particular code jurisdiction.

4. Short form or outline version of the entire master, by excluding paragraphs not needed for that version.

5. Divisions 0 and 1 only, selected and edited for particular contract types. 



Project Links

To add new links to the project:

1. Position the cursor on the paragraph which is to be the link source, open the option panel and set it to show link 
targets.

2. Scroll the screen to show the paragraph which is to be the link target.    Don't move the cursor off the link source 
– use the scroll bar and don't click in any other text cell.    The target can be anywhere in the project, including a 
different section.    You can open 2 sections at a time by minimizing or not maximizing the first section, then going
back to the Project Window and opening another section.    To display them neatly, minimize the Project Window, 
then pull-down the Window Menu and select "Tile Side-by-Side".    When 2 sections are open, one is always the 
"current" window, just as with Windows Icon Group Windows – the title bar is a different color.    You can switch 
back and forth between them and as long as you don't click in any text cell the cursor positions stay the same in 
each.

3. When the target paragraph is visible, using the mouse, position the cursor over the hierarchy level column.    Now
hold down the left mouse button and drag the cursor over to the link target window and drop it.    A link record 
should now show up, with a green arrow pointing to the right, indicating a positive link to the target.    To change 
the type of link, double-click on the green arrow – it toggles to yellow, and with another double-click, to red.

4. The link should take effect immediately.

DETAIL LINKS:    Links to or from choices are called "detail links".    The normally grayed out button to the right of the 
links button is the detail links button.    When the links panel is current (click in the cells of the links), the detail links 
button is active.    Clicking on it opens the detail links dialog box for the link the cursor is on.    Here you can modify the
type of link by selecting:

1. Whether the source is from the paragraph or a choice, and if a choice, which choice.

2. The same thing for the target.

3. The "influence" – type of link (at the bottom of the box).

Changes are reflected in the links panel after the dialog box is closed, using the notation described in Help -- look up 
"status" in Search (black dots indicate choices are involved).



Adding References

Reference citations to correspond to added paragraphs will be handled in the same manner as references in the 
master if they are added this way:

Add the paragraph in the body of the section which contains the reference.

Add a paragraph in the Article References in Part 1, containing the citation.    To make this work, you need to copy an 
existing reference citation paragraph that has the same edition date (remember, you can copy from other sections 
too) and then edit it.    Format the reference designation (e.g. ASTM A 36) exactly like the ones in the master – the 
acronym and number must be followed by a space, a hyphen, and a space.

If you are going to use Section 01425, add the citation in the appropriate location in that section, using the same 
technique as described above.

Using the Project Linking function, add a link from the new paragraph citing the reference to the citation in the 
References Article. 

Pull down the Tools Menu and select Update References.    (This will take a little while, since it is rebuilding the list of 
references for the entire master, so do it last after you've added all the references you need.)

Now when you select the new paragraph containing the reference, and you have either of the references options 
checked in the Summary Info box, the appropriate citations will automatically be included.



Importing - Preparing Text

The Import from Clipboard function uses the current contents of the Windows clipboard and makes certain 
assumptions about the contents.    To make importing more reliable, prepare the text to be imported in your word 
processor first.    Any word processor or text editor that will copy to the clipboard may be used.

Paragraphs:    Each paragraph in the original text will be pasted consecutively into a separate new paragraph in the 
section.    A hard return (WordPerfect) or a paragraph mark (Word) is used to determine the end of a paragraph.    If 
there are too many "end of paragraph" marks or codes, you will find that the text is broken up into too many individual
paragraphs.    If you are uncertain about where paragraphs end, turn on whatever function is used to display the 
paragraph marks or codes and view them.    

Levels:    The first paragraph is inserted at the level of the paragraph that the cursor is on, just like an ordinary copy 
and paste.    However, if there are any tabs or indents in the original text, they will be used to demote subsequent 
paragraphs appropriately, keeping the original hierarchical arrangement.    These tabs and indents must appear at the
beginning of the line.    Indentation accomplished by changing the left margin (as Word usually does it) will not be 
interpreted as a tab -- these paragraphs will not be demoted automatically, although you can adjust the level after 
they are imported.

Paragraph Numbering:    If the imported text contains paragraph numbers made using either text characters or word 
processor codes, you should delete them unless you wish the paragraph numbers to appear in the text.    (When the 
word processor sends the file to the clipboard it converts numbering codes to actual text.)

Other Characters:      The text imported from the clipboard is ASCII text.    Besides letters and numbers, and tabs and
carriage returns, the only characters that will be imported are those in the standard ASCII character set -- those on a 
standard keyboard.



User-Added Choices

In user-added and copied paragraphs, embedded choice options similar to those in master paragraphs can be added.
Building choice options is more time-consuming than simply adding the text that is needed and is, therefore, 
principally useful in an office master.    Links can be added to user-added choices.

To add choices to an existing paragraph:
1. First, copy an existing master paragraph or add a new paragraph with some text in it.

2. Position the cursor in the Edit Panel at the location where the new choice options are to be inserted.

3. Pull down the Choices Menu on the Tool Bar and select Add Choice.    The Choices dialog box will be empty.

4. Click the pull-down arrow at the right end of the Choice Type field.    The pull-down list shows the same types as 
those that appear in master paragraphs, plus the special types for replaceable terms ("architect," etc.) and units 
of measure .    "Optional" types will automatically insert the choice "None - N/A" at the end of the option list.    
Choice types can be combined.    For example, an entire choice group can be exclusive multiple choice, but 
individual choice options can be fill-in-the-blank or unit of measure.

5. First select the choice type for the overall group, press Add, and wait a moment.

6. The words "<new choice>" will appear in the Current Choice box.
· If you selected an optional choice type, the words "None - N/A" will appear under the "new choice".
· If the choice is to include units of measure, check the UOM box.    Four individual text boxes will appear, for 

each of the four unit of measurement settings.    For unit of measurement choices, enter the four versions of 
the text in each box, unless you know you will never use one of the units display options.

7. Enter the text of the first choice option in the Current Choice box(es).    The new choice text will appear in the box
above.
· To make a choice option with a fill-in-the-blank, enter a blank [____] by typing a single left bracket, several 

underscores, and a single right bracket, with no spaces.    The blank may be combined with other words.
· The replaceable terms cannot be inserted into choices -- instead insert them directly into the paragraph text 

as a choice group.

8. To add another choice option, press Add and enter the text.

9. Continue in this manner until all the choice options have been entered.

10. When the choice group is complete, press OK.    Now, the new choice group with the first option as the default 
appears in the paragraph.    If you double-click on the words inside the brackets the choice list pulls up just as it 
does on master paragraphs.

To edit an existing set of choices:
1. Position the cursor between the brackets, pull down the Choices Menu and select Edit Choice.

2. Select the choice option to edit and make the changes in the Current Choice Text box.    Multiple changes can be 
made.    (The choice type cannot be changed -- if that is necessary, remove the existing choice and build a new 
one.)

3. If a choice option must be removed, select it and press the Remove button.    If links are attached to this choice 
they will also be removed.

4. When the changes are complete press OK.

To remove an entire choice group:

1. Position the cursor between the brackets, pull down the Choices Menu and select Remove Choice. 

2. Be sure you wish to delete the choice group -- it's not possible to UNDO this.



Model Project for Professional Office Building

This model project includes all specification sections that would reasonably be found on a project of the following 
type:

· Suburban location, 2 to 3 stories, approximately 14,000 square feet.
· Slab-on-grade first floor, caisson foundation, and steel-framed second floor and roof construction.
· Exterior of brick veneer over metal studs, aluminum storefront framing, tinted insulating glazing, and built-up 

roofing.
· EIFS-clad canopy at entrance with metal-framed skylight and single-ply roofing.
· Interior finishes of painted drywall, fire-resistance-rated lay-in acoustical ceiling panels, carpet, hollow metal door

frames, and flush wood doors.
· Lobby finishes of slate flooring and paneled walls, with a hydraulic elevator.
· Mechanical and electrical systems.
· Site improvements include paving and lawns.
· Bidding and contract requirements, and general requirements (Div. 0 and 1).

Specifics relating to code requirements and structural loadings have been left blank.
Users will need to verify all selections and inserted information in all sections for their specific application.

To use this model project, install from the CD-ROM using the Setup program.    The project file will be located in the 
SpecLink Projects directory, called PROFBLDG.SLP.    Then either copy it to a new file name or use Select Project 
Setup to set it as the default for New Project.



Help on using Help

What's new?

What do you want to do?

See an overview of SpecLink

Build or open a project

Work on the project specs

Print the specs

Print the Table of Contents

Print project requirements reports

Export to word processing

Close the project and exit

Update a project to latest master

Make an "office master project"

Get technical support



Overview Menu

What is SpecLink?

Key Features

Linking Basics

Exploring the Windows and Menus

Quick Start Summary of Project Production



What's new

Summer 1998.

· Manufacturer names are now included in most sections in Divisions 2-14.    The listings were selected from 
those most users would be likely to want to include, for convenience and to eliminate some typing.    The listings 
are not comprehensive, nor should use of them substitute for product research.    Future updates will include 
listings in sections in Divisions 15 and 16.

· A new "model" project is available. A specification for a simulated suburban professional office building is 
now included on the CD-ROM and can be installed from the CD-ROM Setup menu.    If your project is reasonably
similar to the model project your spec writing time may be significantly reduced.    The project file name is 
PROFBLDG.SLP and will be located in your SpecLink Projects directory.    Click here for a description of the 
scope and materials.    To use the model project, keep on reading.

· You can set up your installation so that whenever you select "New Project" the software automatically copies a 
project of your choice, rather than opening a blank project.    You can use the new model project described above
or any project you consider your "office master."    At the File Menu, Select Project Setup, and choose the correct 
project file.

What was new in previous versions



What was new for Winter 1996:

· Proprietary specs:    Arcat SpecDisk sections are now available for all catalog subscribers.    ARCAT sections are 
marked with a checkmark in the far left column of the project window, with the heading of "P".    The acronym to 
the right of the section number indicates the manufacturer on whose products the section is based.    Click on 
"Show Notes" for more information.    

· Draft copy now prints user-added and modified text and notes, as well as master text and notes.    This is useful 
for printing a copy of an office master project, for review and mark-up.

· A new Master Draft Copy button is available at the print dialog box, to print just the master text and notes, if 
desired.

· Choice notations have been modified slightly to make those that are not actually options more identifiable.    In 
the Edit Panel, certain words are surrounded by brackets but are not actually user options.    Examples are the 
replaceable terms for the design professional, the owner, etc., and units of measure that are not options.    These 
types of "choices" are now "grayed out" in the Edit Panel so it is clear that no option is available.    In the Text 
Cells, no change in notation has been made.

What was new in previous versions  



What was new for Fall 96

· Undesired fill-in-the-blanks can now be hidden.

· The Show/Hide Notes button on the Project Window Tool Bar brings up a description of the section contents 
without opening the section.

· Spell check one section at a time, using the new button on the Tool Bar  (next to the print preview button) or 
on the Tools Menu.

· Find and Replace.    Use the Find button  or pull down the Edit Menu and select Find/Replace.

· Embedded choices, replaceable terms, and units of measurement can be added to user-added or copied 
paragraphs.

· Section numbers now consist of 5-digits plus 1 or more letters (the acronym).    To view acronyms, select Status 
Columns on the View Menu.

· Several new normally-hidden Status Columns have been added at the Project Window:    Proprietary, Author, 
and Acronym.

· Word and WordPerfect files containing all the section numbers and titles are included on the CD-ROM for use as 
a project checklist.

What was new in previous versions



What's new in Version 1.1?

Mechanical/Electrical and Civil Catalogs are now complete.

Making choices and entering fill-ins has changed. 

New Functions:

· Importing text from word processing

· Printing a draft copy.

· Promote and Demote paragraph and "branch" buttons on toolbar

· Widow and orphan control

· Zoom in Print Preview

· Table of Contents page count is now optional



Window Menu

There are 3 principal views or windows in SpecLink:

the Main Window,

the Project Window , and 

the Section Window.



Building or opening a project

Before any section text can be edited, a project must be open.    What do you want to do?

Start a new project

Open an existing project

Copy a project

Learn about what the Project Window is showing me.

Next



Starting a New Project

To start a new project, pull down the File menu and select New Project, or 

click on the New Project  button on the Toolbar.

When the Name New Project dialog box appears, enter a file name for the new project in the window at the top left.    
Use the file extension .SLP so SpecLink will recognize the file as a project file.

The drive and directory paths displayed in the other windows will be either the default or the last path you used.      
When the project name and path are correct, press OK.

Instead of starting a new project, you can also Open an existing project and Copy an existing project.

Next



Opening a Project

To open an existing project:

Pull down the File menu and select Open Project, or

pull down the File menu and select the name of the project from the list of most recently used projects that appears at
the bottom of the menu, or

click on the Open Project  button on the Toolbar.

When the Open Project dialog box appears, click on the file name of the project from the list in the window at the left.  
When the correct file name is in the window at the top left, press OK.

If there is a file name in the window at the top left, that is the name of the last project that was open -- if that project is 
to be opened this time, simply press OK.

Click here if the "Applying Master Updates" dialog box appears after selection of the project to open.



Copying a Project

It is safe to copy an existing project in order to re-use previous work because all the master text and options are still 
there, even though they may not have been used on that project.    To copy a project:

Pull down the File menu and select Copy Project.

When the Copy From Project dialog box appears, click on the file name of the project to be copied.    When the 
correct file name is in the box at the top left, press Enter.

If the project to be copied does not appear in the window at the left, change the drive letter and directory path in the 
other windows until the file name desired appears.

Instead of copying a project, you can also start a New Project and Open an existing project.

Next



Project settings

After your new project has been named, you will probably need to modify the default project settings so the Summary
Info dialog box is presented next.

Here you can enter the:

Project name.

Project number

Keywords

You should also select the:

Units of measurement

Next



Project settings for an existing project

You will probably need to modify the project settings.

Open the project.

Open the Summary Info dialog box.

Here you can change the:

Project name.

Project number

Keywords

You should also confirm or change the:

Units of measurement

References settings

Related Sections setting

Next



Working on the project spec

What do you want to do?

Print a draft copy to review the master text

Add or open a section

Delete a section

Edit the text of a section

Include text globally

Use specifier notes

View links for information

Close the section



Adding sections

Before a specification section will print, it must be added to the project and opened, and text must be selected.    What
do you want to do?

 Add a master section

Copy a section

Create a section on a subject not included in the master database

Open an existing section

Open a section without adding it to the project

Open more than one section at a time

Learn about what the Section Window is showing me.

Next



Selecting a Section

To add a section to a project from the master database, the section must be selected.

First, click on the appropriate Division Tab, then do one of the following:

Double click in the status box to the left of the section title, or

Position the cursor on the section to be added by clicking once on the title.    Pull down the Section menu and select 
Change Status, then click on Selected, or

Position the cursor on the section to be added by clicking once on the title.    Click on the Select Section button just 
above the Table of Contents.

An X will appear in the box and the title cell background will turn white to indicated that it is active.    Now you can 
open the section.

Instead of adding a section in this manner, you may also Open the section without selecting it, to decide whether it is 
the correct section.



Copying a Section

Any existing section may be copied to a new number in the current project or to another project.

To copy a section within the same project, position the cursor on the section to be copied.

· Pull down the Section menu and select Copy Section.

· When the Copy Section dialog box appears, the current section number will be in the box indicating the section 
to be copied.    

· Enter the section number, acronym, and title the section is to be copied to.    If you enter a section number and 
acronym combination already used, the copy will not be allowed.

· Press OK.



Copy Section to Another Project

To copy a section to another project:

· Open both projects at the same time.

· Position the cursor on the section to be copied.

· Press the Copy Button on the Tool Bar.

· Click on the Title Bar or anywhere in the Project Window of the project to copy to.

· Press the Paste Button on the Tool Bar.    The section will be pasted into the appropriate Division.



Adding a New Section

To start a section on a topic not contained in the master database, first open an existing project or start a new project.

Pull down the File menu and select New Section, or

click the New Section button just above the Table of Contents.

When the Add Section dialog box appears, enter the section number, acronym, and title of the new section.    When 
the section number and title are correct, press OK.

The new section will be created and added to the Table of Contents, marked with a blue icon to indicate a user-added
section.

The text of the section initially consists of basic "boilerplate" or "example" language which you may select or ignore.    
Add, delete, and edit paragraphs as required.

Click here to see an outline of the contents of new sections created in this manner.



Opening a Section

To open a section that has already been selected, or to open a section without selecting it:

Go to the Project Window, position the cursor on the title of the section to be opened, and do one of the following:

Pull down the Section menu and select Open Section, or

Click the Open Section button just above the list of sections, or

Double-click quickly on the title.    (Double-clicking more slowly opens the title window for editing the title.)

You can open more than one section at a time.



Opening More than One Section at a Time

To open another section, either minimize or restore the current section to less than the full screen.

Click on the Project Window to make it active.

Open another section.

Now you can switch from one section to the other by simply clicking on the section window to make the section 
active.    You can also pull down the Window Menu and select the section you wish to be current from the list at the 
bottom of the menu.

You can also Tile 2 or more sections.



Tile

To fit two or more sections into the screen so you can see both at the same time, "tile" them.

Pull down the Window Menu and select either:

Tile Side-By-Side, or 

Tile Vertically.

All the windows currently open will be tiled.

To see only sections, minimize the Project Window before tiling (don't close it -- that closes the project).



Deleting a section

A section that is part of the master database cannot be deleted from the Table of Contents.    To remove it from the 
project, change its status to neutral .

Delete a master section

A user-added section or a copied section (which is essentially a user-added section), can either be made inactive 
(non-printing) or completely deleted from the project.

Delete a user-added or copied section



Deleting a Master Section

To delete a master section from the project:

At the Project Window, select the appropriate Division Tab, and position the cursor on the section to be deleted.

Double-click in the status box to the left of the section title until the status is neutral.    This "de-selects" the section -- it
will not print.

Click here if the status box remains yellow.

Click here if the status box is green.



Section Recommended by Links

The yellow status box indicates that this section is relevant to the project in some way.    Another section includes a 
link to it.

To identify the reason and resolve it:

Open the section without selecting it.

View the link sources for the section title.

Identify the section and the paragraph that includes the link to the section title.

You can now either:

Ignore the link:    the section will not print.

Change the section that includes the link, or

Select the recommended section again.



Section Selected by Links

The green status box indicates that this section was selected by a link in another section -- it will show on the list of 
sections that can be printed.

If you still do not want the section to be in the project, you can either:

Exclude it:    Change its status to excluded    , 

by double-clicking twice, or

by pulling down the Section Menu, selecting Change Status, and selecting Exclude.

Or, you can:

Remove the link that selected it:

Open the section without selecting it.

View the link sources for the section title.

Identify the section and the paragraph that includes the link to the section title.

If the paragraph that includes the link was selected by the user, de-select it.

If the paragraph was selected by a link, either exclude it or identify the source of that link and remove it.



Deleting a User-Added or Copied Section

To make the section inactive, change its status to neutral    .

To delete the section completely, pull down the Section Menu    and select Delete Section.



Selecting text globally

About Project Requirements

To include relevant text on project requirements in any section:

Open the Project Window and select the appropriate Division Tab.

Find the section for which the project requirements will be included.

Find a button in the column representing the appropriate requirement.

To include the relevant text, press down the button.

If the button turns green, the relevant text is now active and will print.

Click here if the button remains gray.

Click here if the button turns red.



Project Requirement Paragraph Not Yet Active

If the button remains gray, the relevant paragraph has been included but is not yet active.

Open the section and be sure that there is an unbroken hierarchical chain of selected paragraphs leading down to the
relevant text.



Project Requirement Paragraph Excluded

If the button turns red, the relevant text has been excluded, either by the user or by a link.

To correct this, open the section:

If the paragraph status looks like this  , the paragraph has been excluded by the user.    If that is incorrect, double-
click in the status box until the user status indicator disappears.    The box should now be plain green and the 
paragraph cell should have a white background, indicating that the paragraph is active.

If the paragraph status looks like this , the paragraph has been excluded by a link that over-rides the Project 
Requirement selection.    If this is incorrect, you can either:

Select the paragraph, making the status look like this , or 

View the paragraph's links and correct the situation.



Using Specifier Notes

Specifier notes can be viewed at either the Project Window (where the list of sections appears) or the Section 
Window (when a section is open).



Notes at Project Window

At the Project Window, press the Show Notes button on the Tool Bar.

A window will open at the lower right, showing the note for the title of the current section.    This note gives a short 
description of the section contents, plus other information that may help you decide which section to use.

To view the note for another section, simply click the mouse on its title, or move the cursor with the up and down 
arrows.

To close the notes window, press the Hide Notes button on the tool bar.

Tip:    The note cannot be edited here -- open the section to make changes.



Notes at Section Window

Whenever a section is opened, notes appear in the Option Panel on the right-hand side of the screen.

Paragraphs that have notes are marked with an icon in the "N" column to the left of the status column:

 Master note.
 Project note.

To modify a note, position the cursor in the note text and type.    When you move the cursor out of the Notes Panel, 
the changes are automatically saved.

If Links are shown in the Option Panel and you wish to see Notes, press the Notes button on the Section Tool Bar.

To close the Notes Panel, press the Option Panel button on the Section Tool Bar.



Viewing Links

To view the links for a paragraph, position the cursor on the appropriate paragraph.

Open the Option Panel if it is not open, by pressing the Option Panel button on the Section Tool Bar.

Press the Links button on the Tool Bar.

Click here for details on links.



Editing the specs
After opening a section, select the text required.    What do you want to do? 

Move to text to be edited

Select, de-select, or exclude a paragraph

Select choices within paragraphs

Add a new paragraph

Modify a paragraph

Change the level of a paragraph

View the master text  of a paragraph that has been edited.

Copy a paragraph

Delete a paragraph

Import text from a word processing file

Check spelling

Close the section

Click here to learn more about status indicators



Selecting, de-selecting, and excluding paragraphs

A paragraph must be active before it will print in the project and all active paragraphs will print.    Paragraphs are 
made active by changing their status, both by the user and by the system.

Select 

De-select

Exclude

Click here to learn more about status indicators



Selecting a paragraph

Double-click with the mouse in the status box to the left of the text cell until the status box contains an X:  or 

 or 
. 

(Each double-click toggles through "neutral," selected, and excluded, and applies the relevant links each time.)

or

Click on the text to make the paragraph current.    Pull down the Paragraph Menu, click on Change Status. The 
current user status state will be indicated by a check mark.    Click on the desired status to change the status and 
apply links resulting from the change.

Next



Excluding a paragraph

Double-click with the mouse in the status box to the left of the text cell until the status box is half blocked out:  or 

 or 
 or 
.

or

Click on the text to make the paragraph current.    Pull down the Paragraph Menu, click on Change Status. The 
current user status state will be indicated by a check mark.    Click on the desired status to change the status and 
apply links resulting from the change.

Next



Deselecting a paragraph

Double-click with the mouse in the status box to the left of the text cell until the status box is empty:     or 

.    
(If the box remains green , you can exclude it to remove it from the project.    You can also view the link sources to 
identify the reason the software selected it.)

or

Click on the text to make the paragraph current.    Pull down the Paragraph Menu, click on Change Status. The 
current user status state will be indicated by a check mark.    Click on the desired status to change the status and 
apply links resulting from the change.

Next



Choices

Within many paragraphs are choice option groups, indicated by text surrounded by square brackets [ ] and by 
[bolding] in the Edit Panel.

Choice types are:

Exclusive multiple choice

Inclusive multiple choice

Fill-in-the-blank

What do you want to do?

View choice options

Change the current choice

Enter text in a blank



Exclusive multiple choices

These choices include 2 or more options, one of which must be selected, but only one.    They sometimes include a 
"None - N/A" option, which allows all to be omitted.



Inclusive multiple choices

These include 2 or more options, one or more of which must be selected.    These options are automatically 
punctuated properly and joined with the word "and" or "or" as appropriate.    They sometimes include a "None - N/A" 
option, which allows all to be omitted.



Fill-in-the-blanks

The user must enter a word, phrase, or number to make the text complete.    These are shown in the text as [[_____]].

Fill-ins can stand alone -- be the only option of the group.

Fill-ins also occur as one of the options in multiple choice groups.

Entering Fill-Ins

Hiding an Undesired Fill-In



Viewing choice options

For each choice group one option is initially chosen in the master, the "default".    In some cases, the master text has 
been pre-edited to show all the options available (inclusive multiple choice).    Optional words and phrases appear, 
unless they are very unusual.    Fill-in-the-blanks are blank.

To view the other choice options available and make changes:

Open the Edit Panel.    Each choice group is represented in the Edit Panel by the current option selection.

Double-click on the bolded choice text to display the list of options available.    (Choices that are "grayed out" do not 
have any options.)

Next



Making Choices

After the list of options is displayed, the current option can be changed.    Each option has a selection box or circle to 
the left:     for exclusive options, 

 for inclusive options.
Click on the selection box/circle for the desired option.

To return to your original selection, press the undo button    .

To save the changed selection, click anywhere outside the choice list.

Next



Entering text in a fill-in

To enter text in a fill-in, click between the brackets to mark the block and then type the text.    The underscores are 
automatically removed.

If the fill-in you wish to use is one of a multiple choice group, first select the fill-in as you would any other choice, so 
that it appears as a blank in the Edit Panel.    Then click between the brackets and type in the text.

Next



Hiding Undesired Fill-Ins

If you don't want or need to enter anything in a blank, you can hide it.

Enter the words None - N/A in the blank and then click outside the brackets.    In the spec cell and when printed, the 
bracketed words will disappear.

Be sure to enter the words exactly as spelled and formatted above, using a space-hyphen-space between them and 
a slash between N and A.    (This is the same format as for optional choices.)

In most cases, you will also have to edit the text outside the blank, since the blank existed to complete some thought 
or concept.

Note:    If the blank is part of a choice option, with other text, this technique will not effectively hide the choice, 
because the choice text is not editable.    In that case, you must copy the paragraph and edit the copy.

Next



Adding a new paragraph

To add a new paragraph:

Position the cursor on the paragraph above which you wish to add the new paragraph.

Pull down the Paragraph menu and select New Paragraph, or

click on the Insert Above button on the Toolbar.

If the Edit Panel is not already open, open it.    Then type in the new text.

To save the new text, click anywhere outside the Edit Panel.

See Also:    Delete Paragraph, Add Choices Within Paragraphs 



Editing a paragraph

To edit a paragraph, position the cursor on the correct paragraph and open the Edit Panel .

Position the cursor in the Edit Panel.

Edit the paragraph.    Text that is [bolded within brackets] is not editable because it is part of a choice option (except
for fill-ins).

To save press the Save button  or click anywhere outside the Edit Panel.

To undo your changes before leaving the Edit Panel, press the Undo button .

When editing is complete, changes are saved as project text highlighted in blue.

Next



 Modifying master paragraphs

In the text cells of the Contents Panel, choices are surrounded by square brackets [    ] which disappear when the text
is printed.    In the Edit Panel, choices are [bolded and bracketed] -- these are not editable.

 When a "None - N/A" option is current it will appear in the text cell and in the Edit Panel as [None - N/A] but will not 
print.

Two other types of options are also surrounded by brackets, but are not choices -- instead they represent project 
options set at Summary Info on the File Menu.    In the Edit Panel, these options are "grayed out" to indicate that they 
are not choices.    They are:

Units of Measurethat have only one option, and

Replaceable Terms

You can delete an undesired version of project text.

You can also restore the master version of the text, but keep the project version.



Copying a Paragraph

To copy a paragraph, position the cursor on the paragraph to be copied, and do one of the following:

1. Press the Copy button on the Tool Bar, or

1. Pull down the Edit Menu and select Copy, or

1. Press Ctrl+C.

Then, move the cursor to the paragraph below where you wish to paste the copy, and do one of the following:

2. Press the Paste button on the Tool Bar, or

2. Pull down the Edit Menu and select Paste, or

2. Press Ctrl+V.

The paragraph AND ALL ITS SUBPARAGRAPHS will be pasted into the location.

If the copied paragraph is not at the correct level, pull down the Paragraph Menu and demote or promote it or use the
Promote/Demote buttons on the toolbar.

See Also: Add Choices Within a Paragraph



Import Text from Clipboard

To import text from another file, such as a word processing document, you must first copy the text to the Windows 
clipboard.

Open the project you wish to import to and open the appropriate section.

Start or switch to your word processing program and open the file containing the text to be imported.

Mark the text to be copied and select the Copy function from the applicable menu or press Ctrl-C.

Switch back to the project section and position the cursor on the paragraph above which you wish to paste the 
imported text.

Pull down the Tools Menu and click on Import from Clipboard or click the Import button on the toolbar.

If the imported text is at the wrong level, use the Promote/Demote function to adjust the levels.

More on preparing text for importing. 



Closing a section

When the section is complete, close it:

Press the Close button on the Section Tool Bar, or

Pull down the File Menu and select Close Section.

If there are pending changes that have not yet been saved, you will be so notified.

Close Project, on the File menu, will also close all sections that are open.



Before Printing

Before you print you may wish to:

Modify the project settings.

Modify the page layout

Modify the Header or Footer

Modify the paragraph font or    format

Preview on-screen.

Next

See Also:  Making an office master printing setup



Modify page layout

To modify the page layout: 

1. Pull down the Format Menu and select Page Layout, or

1. Pull down the File Menu and select Page Setup.

2. In the Page Setup dialog box, change the settings as required.

Click here for details on page layout variables and defaults.

Next



Page Layout Defaults

The following layout characteristics are defined for the document as a whole, using the Page Setup option on the File 
Menu, or from the Format Menu.

Paper orientation

Margins

Columns on page

Headers and footers

The following layout characteristics are set at the time of printing using the Print dialog box, from the File Menu:

Line numbering

Widow/Orphan control



Modify Header/Footer

To modify the header or footer:

1. Pull down the Format Menu and select Header/Footer, or

1. Pull down the File Menu, select Page Setup, and click on the appropriate Header/Footer Tab.

2. Press the "Customize" button for either the Header or the Footer.

3. Position the mouse cursor in one of the 3 header/footer sections:    Left, center, or right.

4. Using the "keyword" buttons, insert the appropriate keyword codes into the section.

5. Insert any other text required, by typing.

Click here for details on header/footer default formats and "keywords."

Click here to set the page layout to alternate the header/footer left and right

Next



Modify paragraph format

To modify the paragraph format, pull down the Format Menu and select Paragraph Format.    In the Paragraph Format
dialog box:

1. Select the basic paragraph format scheme from the three pre-defined schemes.

2. To modify the scheme, press the Modify button.

3. Change the settings as required.

Click here for details on paragraph format variables and defaults.

Once a paragraph format scheme has been modified for the project, the settings are saved.    Either the modified 
scheme or one of the standard schemes can then be used.

Next



Change Paragraph Format Settings

Select the paragraph level: 0 through 6.

For level 0, the section title, you can define 1 of three formats.    For other levels, define:

The numbering format:    select the number type, and enter any text that is to precede or follow it.

Check desired features:

Include Numbers from Previous Level.
Show Number Format
Hanging Indent.
Print in Upper Case

Press the Font button to modify the font.

Adjust the Text Layout if required.



Paragraph Format Variables

The following layout characteristics are defined for each paragraph level, using the Paragraph Format option on the 
Format Menu:

Paragraph numbers

Indentation

Fonts

Line spacing



Office standard page format and printing setup

If you are using an office master project, set up the most commonly used page format and printing setup in that 
project. 

The setup will be copied to new projects along with the sections and other project settings.

If you are not using an office master project to transfer standard information to new projects, you can still use an 
office master project for page format and printing settings, by creating a project with all your preferred settings, but 
without any sections.



Preview

To preview the current section, press the Preview button on the Tool Bar.

To preview more than one section, pull down the File Menu, select Print.    In the Print dialog box select the 
documents to preview, and press the Preview button.

Next



Current Section

The current section is the one that is open (visible), or if more than one is open, the one that is in the active window 
(the title bar shows this).

In the Project Window, the current section is the one that the cursor is on in the Table of Contents.



Printing the specs

To print the current section, press the Print button on the Tool Bar.

To print more than one section, pull down the File Menu, select Print  . In the Print dialog box, select the documents to
print, and press the Print button.



Print TOC

When all sections are complete, or when all sections to be completed have been added to the project, a printed Table
of Contents can be generated.

Two aspects of the Table of Contents page layout that can be modified:

· The header/footer content and layout.

· Whether the page count  of each section is to be printed.

To print, pull down the File Menu, select Print.    In the Print dialog box, select Table of Contents, and press the Print 
button.

The Table of Contents can also be Previewed or Exported to RTF from the Print dialog box.

See Also:    Project Checklist



Project Checklist

To print a complete listing of all the sections for use as a checklist, use the Word or WordPerfect file CHECKLST.DOC
or CHECKLST.WP5 located on the CD-ROM.



Print Project Requirements Reports

When all sections are complete, any of the Project Requirements Reports can be generated.

The only aspect of the Reports page layout that can be modified is the header/footer content and layout.

Pull down the File Menu, select Print.    In the Print dialog box, select the Reports to be printed, and press the Print 
button.

The Reports can also be Previewed or Exported to RTF from the Print dialog box.



Print Draft Copy

To print a complete copy of the master text of a section, position the cursor on the title of the section to be printed.

Pull down the File Menu and select Print  . In the Print dialog box, select "Selected Section" and press the Draft Copy 
button.

Only one section at a time can be printed in draft.



Export to RTF

All of the documents produced can be exported to Rich Text Format (RTF).

Why export?

About RTF

To export to RTF, pull down the File Menu and select Print.

In the Print dialog box, select the documents to be exported.    Each document or set of documents that is to be in a 
separate file should be exported separately.

When the documents are selected, press the Export button.



Closing a project

To close the project, pull down the File Menu and select Close Project.

To close the project and exit, pull down the File Menu and select Exit.

If any unsaved changes are pending, you will be so notified.



Updating a Project

When a new master database is received, any existing project can easily be updated to the new master, without 
losing any project-specific work.

To update a project:

Open the project.

When the "Applying Master Updates" dialog box appears, select the desired option:

1. Do Not Apply Master Updates to Project, or

2. Show Project Paragraphs Affected by Master Updates, or

3. Apply Master Paragraph Updates to Project.

Options 2 and 3 each take about the same length of time and take more time than option 1.

Click on the appropriate option for more information about its effect on the project and procedures for evaluation of 
updates.

Click here for more information about updates.



Show Updates

If you choose to have the changes shown, the updates that affect sections already in the project will be marked for 
easy identification.    When an updated section is then opened, the changes can be located quickly and viewed.    In 
addition, an update report itemizing all changes can be printed.

Changed paragraphs are highlighted in magenta in the Contents Panel.    To view the updated master text, position 
the cursor on the relevant paragraph, pull down the Tools Menu and select View Updated Master Paragraph.    Follow 
the instructions for viewing and accepting the update.    If the paragraph was already modified for the project, you may
wish to keep the original version or modify the updated version to suit the original changes.    Note:    Sometimes 
paragraphs are marked as updates but the only changes that occurred were in choices that you didn't use in the 
project -- in that case, there will be no visible difference between the old and new text until you accept the update.

Deleted paragraphs are identified in magenta and excluded -- to find them, look for the excluded status box,  or 

 or 
 or 
, plus magenta text.

Added paragraphs are identified in magenta, but not selected .

Under this option, all updates that affect any section that is not in the project automatically take effect.



Apply all updates

If you choose to update everything, the revisions in the master are used instead of the old master data.    Project 
modifications are retained.    In addition, an update report itemizing all changes can be printed.

Changed paragraphs will have the new master text substituted, unless there is already a project version of that 
paragraph.    If there is a project version, that remains displayed with its light blue icon  in the Source column and 
the new master text is concealed.    If there was no project text a yellow icon 

 appears, the new master text is displayed, and the old master text is copied to project text.    In both cases, you can
"toggle" between them using the Restore Paragraph from Master/Project on the Paragraph Menu.    Note:    In the 
case of deletion of choice options, it may not be possible to automatically update a paragraph -- use the update report
to identify paragraphs that may need to be examined.
Deleted paragraphs will be copied to project text with the dark blue icon     in the Source column, and marked as 
excluded, 

 or 
 or 
 or 
.    If a deleted paragraph is needed, change its status to selected.

Added paragraphs will be inserted in the proper location but will not be selected .



No updates

If you choose no updating, no changes of any kind are made to the project text.    However, the Table of Contents will 
be updated to reflect the current section listing.

The software will continue to detect that the master is newer than the project, so that updating can occur later if 
desired.



Spelling

To check spelling in a section, open the section and position the cursor at the title.

Press the spell button  on the Tool Bar or pull down the Tools Menu and select Spelling.

When the speller finds a word not in its dictionary or in your custom dictionary, it presents the following options:

Ignore -- Select this if the word is all right but you don't wish to add it to the dictionary.

Ignore All -- Select this to ignore all other occurrences of this word in this section.

Change -- If the speller found an alternative word or words they are displayed and the first one is suggested.    To 
change the spelling, select or edit the word in the Change To box and press Change.

Change All -- Select this to change all occurrences of this word in this section.

Add -- Select this to add the word found to the custom dictionary; it will be used when checking spelling thereafter.

Note:    The custom dictionary file is a plain text file located in the SpecLink install directory, called CUSTOM.DCT.



Active Paragraph

Text that will appear in printed document is considered active and is shown on a white background.    To be active, 
text must have been selected either by system or user and have complete active "parentage" up to title of the section.



Change Status

Use Change Status on the Paragraph Menu to change whether a paragraph will be included in the project or not.

Click here for more information on Status.



Parent

Each paragraph at level 2 and up has a "parent":    the first paragraph above that is at a level lower than its own (to 
the left).    Complete, active parentage refers to a paragraph having an active parent, whose parent is also active, and
so on, all the way up to the section title.

The hierarchical arrangement of text prevents "child" text from becoming active until its parent is active.    In addition, 
text cannot be "orphaned"—a sub-paragraph is always subordinate to another paragraph (regardless of whether that 
subordination makes sense in the context).

When a user-added paragraph is deleted, all its "children" are also deleted.



Auto Refresh Links

Keeps links up-to-date automatically as text is selected and sections are added.    May be turned off for faster 
operation.

Access this function from the Tools menu at the Section Window.



Refresh Links

Rebuilds all links for specified section, all sections in the Division, or the entire project.    May require some waiting 
time.    This function is relevant only if Auto Refresh Links is turned off.

Access this function from the Tools menu at the Section Window or using the Refresh button  on the toolbar.



Delete Paragraph

Use Delete Paragraph to delete:

· A user-added paragraph.

· The modified version of a user-modified paragraph.

A master paragraph cannot be deleted, only excluded.    See Change Status.

Access this function from the Paragraph menu at the Section Window or using the Delete button on the toolbar.



Restore Paragraph From Master/Project

When a user-modified paragraph exists, toggles between Master text and Project text.

Project text is high-lighted in blue in Edit Panel, with magenta icon in status column.    Master text is high-lighted in 
green in Edit Panel, with yellow icon in status column.

Access this function from the Paragraph menu at the Section Window.



Edit Notes

To edit Notes, position the cursor on the paragraph for which the Notes are to be edited, and open the Option Panel.

Pull down the Paragraph menu, and select Edit Notes.    This positions the cursor in the Notes Panel for editing.

or

Move the mouse cursor to the Notes Panel and click where you wish to start editing.

Edited Notes text is changed to blue, with a magenta icon if modified from master, or a blue icon if new.

Access this function from the Paragraph menu at the Section Window.



Restore Notes From Master/Project

When user-modified Notes exist, toggles between Master Notes and Project Notes.

User-modified Notes are high-lighted in blue, with magenta icon     in status column.

Access this function from the Paragraph menu at the Section Window.



Promote

Use Promote to increase the hierarchy level by one—from 4 to 3, or from 3 to 2, for example.

To promote a single paragraph, use Promote Paragraph.

To promote a paragraph and its subparagraphs, use Promote Branch.

Access this function from the Paragraph menu at the Section Window or from the buttons on the Section toolbar.

See Also:    Demote



Demote

Use Demote to decrease the hierarchy level by one—from 3 to 4, or from 2 to 3, for example.

To demote a single paragraph, use Demote Paragraph.

To demote a paragraph and its subparagraphs, use Demote Branch.

Access this function from the Paragraph menu at the Section Window or from the buttons on the Section toolbar.

See Also:  Promote



Go To

Moves cursor to first paragraph, previous paragraph, next paragraph, or end of section.

Access this function from the View menu at the Section Window or

 use the arrow buttons on the Section Toolbar.



Compact View

In the Project Window, hides all sections that are not in the project.

In the Section Window hides all text that is not active.    Shows only text that will be printed in final document.

Access this function from the View menu or using the view buttons on the toolbar.



Expert View

In the Project Window, hides all sections that have been excluded by the user.

In the Section Window, hides text that has been excluded by either the user or the system.    All other text appears.

Access this function from the View menu or using the view buttons on the toolbar.



Master View

In Master View, every section and all text appears, no matter what its status.

Access this function from the View menu or using the view buttons on the toolbar.



Undo Last Edit

Restores text to condition existing prior to last edit.

Access this function from the Edit menu at the Section Window or using the Undo button  on the Section Toolbar.



Function not yet available

This is a future function not yet implemented.



Delete Project

Prompts for selection of project file name to delete.

Access this function from the File menu at the Project Window.



Select Master

Normally only one master database exists.    Each project is tied to a particular master database.    If more than one is 
available, allows selection of database to match project to be opened.

Access this function from the File menu at the Project Window.



Select Project Setup

The project setup file is used to create a new project.    Originally, only one project setup file exists, matching the 
master database:    MASTER.SLT.    However, any project file created using the original setup file can later be 
designated as the project setup file for all future new projects.    This is useful if an office wishes to require the use of 
an "office master project" as the starting point for all new projects.

If more than one master database is available, allows selection of setup file to match master database selected.

Access this function from the File menu at the Project Window and select the setup file required.



Create Project Setup

Used by the master database developers to create a new project setup file to match an updated master database.

Access this function from the File menu at the Project Window.



Close Section

Ends editing the current section.    All changes made will be saved.      If more than one section is open, click in the 
window of the section you wish to close before selecting Close Section, to be sure that the section you wish to close 
is active.

Access this function from the File menu at the Project Window, or use double-click on the bar in the upper left-hand 
corner of the Section Window (standard Windows function).



Close Project

Ends editing the current project.    All changes made will be saved.

Access this function from the File menu at the Project Window, or use the Close Project button just above the Table of
Contents, or double-click on the bar in the upper left-hand corner of the Project Window (standard Windows function).



Save Project

This is a future function not yet implemented. 

Currently, all changes are saved automatically, eliminating a need for periodic saves.

Access this function from the File menu at the Project Window.



Open Master

The master database cannot be opened for viewing in user mode.

Access this function from the File menu at the Project Window.



Status

The status of each section/paragraph is visually displayed in the box in the status column to the left of the title/text 
using colors.    There are 2 types of status:    user status—reflecting actions taken by the user—and system status—
reflecting links made by the system.

User Status States:

"neutral" text—no action taken yet
selected—marked with an X
excluded—half the box blacked out

System Status States:

"neutral" text—no links made yet
selected—green background
excluded—red background
suggested as relevant—yellow background

Each paragraph has both a user status and a system status at the same time, reflected by a combination of the user 
status indication and the system status color.

In addition, whether the section or text will print or not is indicated by the color of the background of the text or title 
cell.    Active, text which will print in the project is on a white background while inactive text is shown on a gray 
background.

See Also: Change Status



Prompt Bar

On the bottom line of the screen, a bar that contains explanations of the current operation or the function the mouse 
cursor is over.

The prompt bar can be turned off using the View menu.



Line spacing

Line spacing is controlled by defining the number of lines to be skipped before each paragraph of each level.

Example:    In CSI style, 1 line is skipped before levels 2 and 3, but not for levels 4 and up.

Access line spacing through Paragraph Numbering at the Format menu.



Columns on page

The specification may be printed using either one or two columns on the page.    The default is one column.

Two columns can be used with any of the other page layout options.

Set the number of columns on the page at the Page Setup dialog box, reached either from the Format Menu, Page 
Layout, or from the File Menu, Page Setup.



Save Button

Pressing the Save button  on the Toolbar causes the last changes, of whatever type, to be saved.

If a paragraph has been edited, the changes are saved.

If the status of a paragraph has been changed, all consequences of the change are executed.

Regardless of whether the Save button is pressed, when changes are made the software attempts to save them.    To 
cancel a change, do not press the Save button.    Instead, move the cursor to another paragraph.    You will then be 
given an opportunity to cancel.



Section numbers

Section numbers consist of 5 digits and an acronym consisting of up to 5 letters.    Section numbers displayed in the 
window title bar or on the prompt line show the acronym in parentheses.

The number and acronym assigned to each section in the master database is fixed and cannot be changed.

Numbers of new sections created using the "New Section" function and numbers of copied sections are assigned by 
the user and may not duplicate section numbers in the master database.    The default acronym for these sections is 
USER.

The 5-digit numbers in the master database are based on MASTERFORMAT.    It is recommended that new numbers 
be selected from MASTERFORMAT as well, to reduce the likelihood of duplication in the future.    



Section Titles

The titles of sections in the master database are derived from MASTERFORMAT, with variations required to 
accommodate differences in scope.

Titles of new sections created using the New Section function should also be based on MASTERFORMAT to the 
extent that is appropriate.    Titles should be as explicit as possible for good communication, and should not indicate a 
scope that is not accurate for the section.



References

In the Summary Info dialog box are 3 check boxes for References.    Check any or all if you wish the function to occur:

Include in Part 1 of Each Section:    This turns on the References Article title whenever there is a reference 
included.

Consolidated List in Division 01:    This turns on the reference citation in Section 01425 whenever there is a 
reference included by links or selected by the user in any section of the project.    To produce the consolidated list, it is
necessary to include Section 01425 in the project and select the Parts desired.

Show Reference Date on Reports:    This prints the edition date of each reference when the section is printed.    The
edition date always shows while the section is being edited.    To print the dates only in the consolidated list, check 
this box only when printing Section 01425.

Click here for information about adding reference citations that will be handled in the same way as master references.



Related Sections

In the Summary Info dialog box is a check box for Related Sections.    Check it if you wish the Related Sections Article
title to be turned on whenever one of its paragraphs is turned on.



Page Count

In the Project Window in the far right column is a page count for each section.    The page count appears after the 
section has been printed and is reset whenever a change has been made that would affect the output, indicating that 
the section needs to be reprinted.

To print the page count on the Table of Contents, check the box on the Table of Contents Header/Footer dialog box at
Page Setup.



Update Date

In the Project Window, the update date for each section shows the last date a change was made that would affect the
output.    If you widen the column by dragging the right hand edge, the full date and time appear, so multiple changes 
made in a single day can be identified.

Before the section is added to the project, the date shows the last date an update was made to the master database.



Why export?

Export to RTF can be used to "freeze" the project, for further changes by addendum or change order.

It can also be used for archiving, as the RTF files take up less space than the project database files.



Copy/Paste

To copy, use the Edit Menu, Copy and Paste, or the Copy and Paste buttons on the toolbar.

At the time you select Copy or press the Copy button, what will be copied depends on which window or panel is 
current and what the cursor is on. 

See Also:    Copy Paragraph, Copy Section



Cut/Delete

Cut and Delete apply only to user-added paragraphs and sections.    Cut and Delete are available from the Edit Menu.
The Delete button on the toolbar is grayed out when delete is not applicable.

At the time you select Cut or Delete, what will be removed or deleted depends on which window or panel is current 
and what the cursor is on.    If text is marked (blocked), the marked text is deleted.



Status Columns

Some status columns do not open by default.    To view other information at either the Project or Section Windows, 
pull down the View Menu, select Status Columns, and select the column desired.

At the Project Window, see:    Author, Proprietary, Acronym, Catalogs

At the Section Window, see:    Sequence



Author

Sections in the master database have been originated by different authors. 

To view the author identification of a section, pull down the View Menu at the Project Window, select Status Columns 
and Author.



Proprietary

Certain sections in the master database are proprietary sections, based on a particular building product 
manufacturer's products.

To identify proprietary sections, pull down the View Menu at the Project Window, select Status Columns and 
Proprietary.    The column to the far left of the Project Window, marked "P" at the top, indicates proprietary sections 
with a yellow check mark.



Acronym

A section number is made up of 2 parts:    the number and an acronym.

To hide/view acronyms, pull down the View Menu at the Project Window, select Status Columns and Acronym.

See Also:    Section numbers



Sequence Number

Each paragraph in each section has a sequence number, the sequential number that determines its order in the 
specification.    The sequence number of a particular paragraph may change, due to the addition or deletion of other 
paragraphs before it in the section.    At any time, the sequence numbers shown in the links panel correspond to the 
current sequence numbers of the text.

To view the sequence number, pull down the View Menu, select Status Columns, then Sequence.



Show Toolbar

The toolbars are normally visible.    They can be hidden or shown using Show Toolbar on the View Menu.



Show Choices

The Choice Panel is normally visible when the Edit Panel is open.    It can be hidden using Show Choices on the View
Menu.



Update References

When new reference citations have been added, use Update References on the Tool Menu to set their links up 
properly.

Click here for details on adding references.



Navigation

The principal way to move around in the section is by scrolling the text up and down the screen, using the scroll bar.

Use the Levels to Aid Navigation:    Although scrolling and paging down and up through the section is an effective 
way to move around in the section, at times you know exactly where you wan to move to and don't want to waste the 
time scrolling.    In that case, use the "levels" to aid in navigation.    The "Show Levels" buttons on the tool bar and the 
"Contents Levels" on the VIEW Menu both allow you to quickly change the number of levels visible.

Example    Suppose you are in Part 3 reviewing the field testing provisions and wish to skip to Part 1 to see what is 
said about testing under Quality Assurance.    "Collapse" the section to level 1, move the cursor to Part 1, "expand" to 
level 2, move the cursor to Quality Assurance, and then "show all levels."    Now you can scroll through Quality 
Assurance.

Use the Bookmark to Speed Navigation:    In the example above, it would be even easier to return to your original 
position in Part 3 if, before you collapsed the text, you had pressed the Bookmark button on the tool bar.    The 
bookmark would then have been set to the paragraph in Part 3 that the cursor had been on.    When you finish 
reviewing the Part 1 text, press the Return To Mark arrow next to the Bookmark button.    The screen will now display 
the marked paragraph.    If it doesn't, that may be because the marked paragraph is at a level that is not visible.    Just
"show all levels" and press the Return To Mark button again.

Use the Find button to search for specific words.



Technical Support

For assistance in installing or using BSD SpecLink:

Call 1-800-266-SPEC

FAX 1-404-876-0006

Internet E-mail:    BSD@bsdsoftlink.com

Compuserve:    72377,1062

Compuserve via Internet:    72377.1062@compuserve.com

and see our home page at 

HTTP://www.bsdsoftlink.com 

for new product development and other news.



Find/Replace

Find and Replace operate just like the same functions in other Windows programs.    Enter the word(s) to search for, 
select the type of search (Any Part of Text, Match Whole Word, or Start of Text), select Match Case if that is 
important, and select the direction to search (up or down).

When replacing, you can also choose whether to verify each occurrence or simply replace all occurrences.    Replace
operates in the down direction only.

The search begins at the current cursor position and searches only in the currently open section.



Draft copy

A Draft Copy is the complete text and notes of the master and all the changes made to it by the user, whether the text
has been selected for the project or not.    Draft copy is intended for review and manual mark-up and does not 
indicate which text is selected for the project.

Exclusive multiple choice options are set off from the text by braces, with the options separated by vertical bars:

text { first option | second } more text

Other options are not noted in the draft copy.

A variation of draft copy is Master Draft Copy, consisting of all of the above except user changes.

To print Draft Copy and Master Draft Copy pull down the File menu and select Print.    Select the section to be printed 
(one at a time) and press the appropriate button.



File Menu
New Project
Open Project
Open Master
Close Project 
Close Section

Save Project
Copy Project
Rename Project File
Delete Project
Compact Project
Repair and Compact Project

Select Master
Select Project Setup
Create Project Setup

Summary Info
Permissions

Page Setup
Print Preview
Print



Edit Menu

Undo Last Edit

Cut
Copy
Paste
Delete

Find
Replace



View Menu

Compact View
Expert View
Master View

Status Columns 

Save Project Layout as Default
Restore Original Project Layout

Show Tool Bar
Show Prompt Bar



View Menu

Compact View
Expert View
Master View

Contents Panel
Edit Panel
Option Panel

Contents Levels
Status Columns
Set Option Panel

Move to

Save Section Layout as Default
Restore Original Section Layout

Show Tool Bar
Show Prompt Bar
Show Choices



Section Menu

New Section
Open Section
Move Section
Delete Section
Copy Section
Change Status



Paragraph Menu

New Paragraph
Edit Paragraph
Delete Paragraph
Restore Paragraph From Master/Project
Edit Notes
Restore Notes From Master/Project

Change Status

Demote Paragraph
Promote Paragraph
Demote Branch
Promote Branch



Format Menu

Paragraph Format
Page Layout
Header and Footer



Tools Menu

Import Macro File (developer function)
Export Macro File (developer function)

Update References

Refresh Division Links
Refresh Project Links

Update Project to Master

Show Master Links
Show Project Links



Tools Menu

Spelling

Auto Refresh Links
Refresh Section Links

Import from Clipboard
Export Section to Macro File (developer function)

View Updated Master Paragraph
Update Section to Master



Choices Menu
Add Choice
Edit Choice
Remove Choice



Window Menu

Tile Horizontally    - all windows open are arranged horizontally, one over the other.
Tile Vertically - all windows open are arranged vertically, side-by-side.
Cascade Windows    - overlap all open sections.
Arrange Icons

Close Window    closes current window.



Help Menu

Contents    is the main help menu.
Search for Help On... allows you to search for topics directly.
Help on Using Help    provides information about how to use Help.
About SpecLink    gives information about the program.



Bookmarks

To mark your place in a section, position the cursor on the paragraph to be marked.

Pull down the Edit menu and select Mark Item, or

click on the Mark button  on the Toolbar.

Now you can scroll up or down or move the cursor.

When you're finished, click on the Return to Mark button  on the Toolbar to move the cursor back to the marked 
location.

Note:    Return to Mark moves the cursor back, not just the screen view.



Contents Levels

Displays the hierarchical level of the paragraph.    Like "dice", the symbols indicate the level by the number of dots.    

The level determines whether the paragraph is a "child" or a "sibling" or the immediately preceding paragraph, or 
neither.    If a paragraph is a child, it cannot be active unless its "parent" is active.

See Also: Paragraph Numbering Schemes
Promote
Demote



Notes Column

When notes are available for a paragraph an icon appears in this column.    The color of the icon indicates the origin 
of the notes:

Original "master" notes {note text is black}
User-added notes {note text is blue}.

User-modified master notes {note text is blue}.
 



Source Column

When modifications are made, colored icons appear in this column.    The color of the icon indicates the type of 
modification made:

When in the Project Window, the icons indicate:
User-added section, made either by copying an existing section or starting a new section.

When in a section window, the icons indicate:
User-added or copied paragraph.

User-modified paragraph {blue text in Edit Panel}; original master paragraph hidden.
User-modification hidden {green text in Edit panel}.



Spec Cells

The text of each paragraph appears in a cell next to its status box. 

If the text is longer than the space available in the cell, the remaining text is temporarily hidden.    To view the hidden 
text, position the cursor on the paragraph and open the Edit Panel.



Links Button

    Displays links for the current paragraph in the Option Panel on the right-hand side of the screen.    The first click 
displays the Link Sources.    A second click toggles to the Link Targets.



Detail Links Button

Paragraphs may contain links attached to options within choices.

In that case, to view the Link Targets for the options position the cursor on the paragraph and click the Detail Links 
Button  on the Toolbar.

In the detail links box, the current paragraph appears on the top and the target paragraph appears on the bottom.    
Select the applicable choice in the current paragraph.    The paragraph or choice it is linked to will appear, along with 
the "Influence" the link executes.    



Edit Panel Button

Opens the Edit Panel across the bottom of the screen.    Click again to close the Edit Panel.



Exclamation Point

To "refresh" the section links, click the Exclamation Point  on the Toolbar.    This reviews all active paragraphs and 
makes sure that all links from them have been executed.

Refreshing the section links is not necessary if Auto Refresh Links on the Section Tools menu is checked -- in that 
case, links are automatically executed each time a paragraph is selected.



Display Levels Buttons

Series of four buttons that select the number of levels of text to display: 1, 2, 3, or 4 and up.

See Also:    Contents Levels



Project Name

Enter a project name that is appropriate.    This name will be the one used by the header and footer formatter if the 
project name keyword is used.



Project ID

Enter a project number that is appropriate.    This number will be the one used by the header and footer formatter if 
the project ID keyword is used.

The project number does not have to be the same as the project database file name.



Replaceable terms

The terms entered here for the design professional, the owner, the contractor, and the project location will be 
substituted for coded identifications in the text wherever they appear.

Any words can be used, but keep in mind that the sentence syntax and punctuation assume that nouns or proper 
nouns will be used, and that possessives and other structures may be appropriate.

Example:    The use of the term "Adams Brothers Company" instead of "Owner" may result in an awkward sentence 
structure when combined with phrases like "...instruct Adams Brothers Company's personnel...".

Also, the duties of each entity (and what the specification says each will be responsible for) are based on contractual 
relationships similar to those provided for in AIA A201-87 and EJCDC 1910-8, the typical Owner-Contractor 
agreement with the design professional providing construction administration.    If the contractual relationships for the 
project are different from these, substitution of a different set of names may not be sufficient to clarify the modified 
responsibilities.    In that case, it will be advisable to examine each section for statements relating to the duties of the 
parties to the contract and make modifications as necessary.

Example:    Substitution of the term Contracting Officer for the Owner may not adequately modify the specification, 
particularly if the Contracting Officer's duties also include some of the design professional's duties.



Units of Measure

Select the preferred units of measure presentation for the entire project under Summary Info at the File menu:

English (Metric) -- Inch-Pound with SI in parenthesis
Metric (English) -- SI with Inch-Pound in parenthesis
English -- Inch-Pound
Metric -- SI

The units displayed may be changed at any time.

Where dimensions are entered by the user in fill-in-the-blanks, the software does not convert them to the other forms 
of units -- if there is any likelihood of using a different form of units, each filled-in dimension should be filled-in under 
each display option.    Simply change the display and enter the converted units.



Page Setup

Select this TAB to select the printer and set margins, page orientation, and source.



Specification Header/Footer

Select this TAB to edit the header and footer for the specification.



Requirements Reports Header/Footer

Select this TAB to edit the header and footer for requirements reports.



Table of Contents Header/Footer

Select this TAB to edit the header and footer for the Table of Contents.



Printer definition

Define the printer in the same manner that printers are defined for other Windows-based software.



Paper orientation

Portrait -- 8-1/2" x 11"
Landscape -- 11" x 8-1/2"



Margin settings

Enter the top, bottom, and side margins, measuring in from the paper edge.



Header/Footer Distance from Edge

The header and footer are positioned within the margin distance at a certain distance from the edge of the paper.

Note:    It is possible to set the margins and the header/footer distance so that the header/footer overwrites the text -- 
preview before printing if in doubt.



Header/Footer Layout

Normally, the header and footer are identical on every page.    However, there is a setting in the Page Layout dialog 
box to change this to alternate right and left.    The right and left sections of the header/footer are swapped from page 
to page.    This is appropriate if 2-sided printing is used.



Printer Setup

Printer setup is the same as for Windows.



Specification header

The default header for all standard layouts is blank.

To add a header or modify an existing user-added header, select the Customize Header button.



Specification footer

The default footer for all standard layouts has:

Project Name and number at the left, followed by the date.
Section number in the center, followed by a hyphen and the page number.
Section title at the right.

To add a footer or modify an existing user-added footer, select the Customize Footer button.



Reports header

The default header for all reports is blank.

To add a header or modify an existing user-added header, select the Customize Header button.



Reports footer

The default footer for all reports has:

Project Name and number at the left, followed by the date.
The word Page in the center, followed by a hyphen and the page number.
Report title at the right.

To add a footer or modify an existing user-added footer, select the Customize Footer button.



Table of Contents header

The default header is blank.

To add a header or modify an existing user-added header, select the Customize Header button.



Table of Contents footer

The default footer has:

Project Name and number at the left, followed by the date.
The word Page in the center, followed by a hyphen and the page number.
The title Table of Contents at the right.

To add a footer or modify an existing user-added footer, select the Customize Footer button.



Select Documents to Print

There are three types of documents that can be printed:

Specification sections.
Requirements reports.
The Table of Contents.

Only one type can be printed at a time -- click on the button for the type required.

For specification sections, one or more sections can be printed at a time.    Set the Division and sections desired.    
(Exception:    Only one section can be printed in draft copy at a time.)

For reports, one or all reports may be printed.

Before printing, you may wish to set up the printing formats.

See also: Page formatting 
Printer setup.



Set Page Range

Use the arrow keys to set the range of pages to print.    



Line Number Setting

Pages may be printed with line numbers in the left-hand margin.    The default setting for line numbers is none, for all 
standard formats.    To turn line numbers on at the time of printing, in the Print Dialog Box check the box labelled Line 
Numbers.

Line numbers are consecutive, on each line regardless of whether it contains any text, and start over at the top of 
each new page.

Note:    Line numbering is especially useful if the Block format is used (without paragraph numbers).

Reminder:    Line numbering is independent of the page layout and paragraph numbering scheme – it is set at the 
time of printing only.



Widow/Orphan Setting

To turn on widow/orphan control, check the box at the Print dialog box.    This prevents a single line of a paragraph 
from printing alone on the bottom or top of a page.

Regardless of whether this box is checked, a Keep with Next function always prevents level 2 and 3 paragraphs (the 
PARTS and Articles) from appearing alone at the bottom of a page.    Also, END OF SECTION will never appear 
alone on a page -- if possible, it will be pushed back onto the the previous page.    If there is no blank line on the 
previous page, the last paragraph will be pulled forward to print on the last page with END OF SECTION.



Select Level to Modify

Select the paragraph level to be modified (pull down the list using the arrow in the box).



Section Number and Title Format

At level 0, you have the option of formatting the Section Number and Title either all on one line, or on multiple lines, or
of leaving the section number off entirely.    Select the format desired.



Paragraph number format

Each paragraph number consists of three parts:

the text that precedes the number/letter, 
the number or letter that is incremented, and 
the text that follows the number/letter.

For best results:
1. Select the number type:    1, A, or a.
2. Enter any text to precede all occurrences of this level.
3. Enter any text to follow, e.g.    a period or )
4. Set the starting number/letter if not 1/A/a.

Examples:

1. The number would be preceded by nothing and followed by a period.
(1) The number would be preceded by ( and followed by )

To make a number combining the PART number and the paragraph number, such as 1.1.1, indicating the first level 3 
paragraph in the first level 2 Article in PART 1, check the box below for Include number from previous level.

The starting number setting applies to all occurrences of this level in the document -- it would be unlikely that this 
would need to be changed unless you wish to have the PARTS start with some number other than 1 in order to 
append this document onto another document prepared separately.



Include number from previous level

If the number from the preceding level is to be inserted in front of the number check the box, otherwise clear it.    

Example:    Level 2 numbers in CSI style have the preceding level inserted -- 1.01, 1.02, etc. -- but level 3 numbers do
not.



Show number format

Normally the number is to show in the printed document and the box will be checked.    If not, clear the box.    

Example:    Level 1 numbers in CSI style do not print because those paragraphs are formatted as "Part 1 General", 
Part 2 Products", etc.    If the PART title text is changed to eliminate the Part numbers, the Articles (Level 2) will 
nevertheless be numbered as if the Parts had numbers.



Paragraph text layout

Alignment options:    Centered, left justified, and right justified.
The amount of indentation is from the left margin.
The distance to the beginning of the text is from the beginning of the number.

Line spacing is controlled by defining the number of lines to be skipped before each paragraph of each level.    
Example:    In CSI style, 1 line is skipped before levels 2 and 3, but not for levels 4 and up.

Modify the paragraph layout from the Format Menu, Paragraph Format.



Hanging indent

Most paragraphs in the standard formats use a hanging indent by default and the box will be checked.    If a hanging 
indent is not desired, clear the box.

Military style is notable in its absence of hanging indents.

Hanging indent means the same thing that it does in Microsoft Word.
For WordPerfect users, this means an indent rather than a tab.



Print in upper case

Normally, the text is printed exactly the way it appears on the screen.    However, it may be desirable to force some 
levels to print in all upper case, regardless of how they are formatted in the text.    If so, check the box. 

Example:    In CSI style, levels 1 and 2 are always all caps, but levels 3 and up are not.



Open Project Button

Press the Open Project button on the Main Toolbar to open an existing project.

Click here for more information about opening an existing project.



New Project Button

Press the New Project button on the Main Toolbar to start a new project.

Click here for more information about starting a new project.



Add Paragraph Button

To add a paragraph, position the cursor on the paragraph above which you wish to add the new paragraph.

Press the Add Paragraph button.

A blank cell will appear and the cursor will be placed in the Edit Panel.    Type the text of the paragraph and save.

If the new paragraph is at the wrong level, use Promote or Demote  to change the level.



Project Requirements Buttons

For commonly used general project requirements, these buttons at the Project Window allow the inclusion 
automatically of relevant text.

Click here for a description of the topics available.
Click here for how to include text automatically.



Contents Panel Button

Opens and closes the Contents Panel, where the text is displayed.



Option Panel Button

Opens and closes the Option Panel, at the right side of the Section Window, where notes and links are shown.



Save Choice Button

Saves the current choice selection as the active choice.

Make choice selections in the Choice List, then press the Save button.



Notes Button

Displays the notes in the Option Panel.



Close Section Button

Closes the current section. 

There is a Close Section button on the Toolbar of each Section Window.
If you have more than one section open, be sure that you click on the Close Section button for the proper section.



Edit Button

Moves the cursor into the Edit Panel, for editing the paragraph text.

NOTE:    You can also click in the Edit Panel with the mouse to begin editing.



Print Button

Press the Print button to print the current section.



Preview Button

Press the Preview button to preview the current section.



Spell button

Press the Spell button to check spelling in the currently open section.



Find button

Press the Find button to search the currently open section for a word.



Adjusting Window and Column Layout

Both the Project Window and Section Windows can be resized as well as moved.    Panels within each window can be
resized by dragging their edges.    Columns within panels can be changed in width and location in some cases -- if the
cursor changes shape over the border between columns the columns can be changed or moved.

You can adjust the size and arrangement of the windows to suit your working habits and the size and resolution of 
your screen.    When you have an arrangement that you like, you can save it as the default so it is used each time you
start the program.

To save the Project Window layout, at the Project Window, pull down the View Menu and select Save Project Layout 
as Default.    To save the Section Window layout, do the same thing at the Section Window.

Some columns can be hidden or shown using the View Menu, Status Columns.    Others can be hidden by dragging 
them closed.    If you hide a column using the latter method, or if you want to return to the original layout, use Restore 
Original Project Layout or Restore Original Section Layout at the appropriate window.



Main Window
This is the Main Window, where you can:

start a new project,

open an existing project,

copy a project,

rename a project file,

delete a project,

compact a project file,

repair a project file,

view Help.

Once you have started a new project or opened an existing project you will be in the Project Window.    In the Project 
Window you will be able to open and select sections, copy sections, exclude sections, and preview and print sections.

When you have opened a section you will be in the Section Window where you will be able to select and edit text, 
make choices, add new text, view notes and links, and preview and print sections.



The Project Window

Click here to explore the parts of the Project Window and its menus.

This is the Project Window, where the current Table of Contents for the open project is displayed.    All available 
sections are also shown here.

the Menu Bar and Tool Bar are across the top of the screen,

the Table of Contents is in the middle, and

the Prompt Bar is at the bottom.

The Table of Contents displays the status of each section in the project.    The Table of Contents is organized by the 
CSI/CSC MASTERFORMAT 16 Divisions.    To show the sections for a different division, simply click the mouse on 
the TAB for the desired Division.



Project Window Screen      Click on the dotted-outlined areas for explanation of information displayed and function of buttons and 
menus



The Section Window

Click here to explore the parts of the Section Window and its menus.

The Section Window is where the section text, notes and links are displayed, and where you edit the section text.

the Menu Bar and Tool Bar are across the top of the screen,

the Contents Panel is in the middle,

the Option Panel is at the right,

the Edit Panel is across the bottom,

the Prompt Bar is on the bottom line.



Section Window Screen      Click on the dotted-outlined areas for explanation of information displayed and function of buttons 
and menus



Contents Panel

This is the Contents Panel -- the grid where the paragraph text cells are located.

What do you want to do?

See an explanation of the information it shows

Learn what the tool bar buttons do

Display the specification item number (sequence)

Edit the specification text

Change the hierarchy level of a paragraph

View the specifier notes

Hide text that is not active



Option Panel

In the Section Window, the Option Panel displays supplementary information to help in preparation of the section:    
notes, link sources, or link targets.

To open or close the Option Panel, do one of the following:

Pull down the View Menu and click on Set Option Panel.    Then select the type of information you wish to view:    
Notes, Link Targets, or Link Sources.    

or

Click the Option Panel button on the Tool Bar.    Opening the Option Panel defaults to Notes.    To open Links, click on 
the Links button to open Link Sources; click on the Links button again to change to Link Targets.

See Also: Notes

Link Targets

Link Sources



Links Panel

Each paragraph and each choice in a paragraph can have a link to any other paragraph or choice.    Each link has a 
Source and a Target.    The Source is the paragraph which must be selected for the link to take effect.    The Target is 
the paragraph whose status is affected by the link.

The currently effective links for any paragraph can be viewed at any time by opening the Option Panel.

For both Targets and Sources, the Option Panel shows the following information:

The "influence":    The type of link. 

The section number and sequence number of the paragraph affected (target) or influencing (source).

The text of the paragraph affected/influencing.

The type of link is displayed visually:    Link Targets, Link Sources.



Edit Panel

The Edit Panel is used to edit the paragraph text and is located at the bottom of the Section Window. The Edit Panel 
is normally open, but if it is closed it can be re-opened:

To open the Edit Panel, do one of the following:

1. Pull down the View menu and select Edit Panel, or

2. Click on the Edit Panel button  on the Toolbar.

Click here for more information about what is displayed in the Edit Panel.



Choice List

This is the Choice List, where all the available options for the current choice group are displayed.    The current choice
is marked with either a filled-in circle or an X in its box.

To change the current choice, click on the appropriate circle or X-box.      When the choice or choices is correct and 
press the green X button below to save.    To cancel the change, press the Undo button below.

If the choice options involve a fill-in-the-blank, the option containing the blank must be first selected and saved.      
Then the blank can be filled in, by clicking in the blank and typing.

Click here for more on choice types.



Summary Info

The settings at this Project Summary Info screen apply to the entire project. 

Here you can enter or change the:

Project name

Project number

Keywords

You should also confirm or change the:

Units of measurement

References settings

Related Sections setting



Page Setup

At this screen, the page layout for all documents in this project are defined.

Click here for information on page layout default settings.

To modify the header or footer, click the appropriate TAB at the top of the box.



Specification Header/Footer Setup

This window shows the current header and footer contents.

To modify the header, press the CUSTOMIZE HEADER button.

To modify the footer, press the CUSTOMIZE FOOTER button.



Requirements Reports Header/Footer

This window shows the current header and footer contents.

To modify the header, press the CUSTOMIZE HEADER button.

To modify the footer, press the CUSTOMIZE FOOTER button.



Table of Contents Header/Footer

This window shows the current header and footer contents.

To modify the header, press the CUSTOMIZE HEADER button.

To modify the footer, press the CUSTOMIZE FOOTER button.

To include the page count of each section, check the PAGES box.



Customize Header/Footer

To modify the header/footer:

1. Position the mouse cursor in one of the 3 header/footer sections:    Left, center, or right.

2. Using the "keyword" buttons, insert the appropriate keyword codes into the section.

3. Insert any other text required, by typing.

4. PREVIEW the document to verify the changes.

Click here for details on header/footer default formats and "keywords.

Click here for how to set the page layout to alternate the header/footer left and right.



Print Dialog Box

At this screen you define what documents to preview, print, or export.

First select the document(s) to be printed:

· Specification section(s)

· Table of Contents

· Requirements Report(s)

Only one type of document may be printed at a time.    Only one draft copy can be printed at a time.    Multiple project 
sections or reports may be printed together.

For sections or reports, select the documents to be printed.    A selection of All documents, or all documents in a 
Division is possible.

If necessary, press the PAGE SETUP button to modify the page layout.

If line numbers are desired, check the Line Numbers box.

To turn widow/orphan control on, check the Widow/Orphan box.

After the documents have been selected, press the PREVIEW, DRAFT COPY, PRINT, or EXPORT button.

Click here for more information on Exporting.



Paragraph Format

This is the Paragraph Format dialog box, where all format, layout, and numbering options for paragraphs can be 
modified.

1. Select the basic paragraph format scheme from the three pre-defined schemes.

2. To modify the scheme, press the Modify button.

3. Change the settings as required.

Click here for details on paragraph format variables and defaults.

Once a paragraph format scheme has been modified for the project, the settings are saved.    Either the modified 
scheme or one of the standard schemes can then be used.

To change the overall page layout, use Page Layout on the File Menu or the Format Menu.



Update to Master

Updating to a new master will never erase any project information, whether text modifications, choices, or notes.

In all modes of updating, there may be changes made to links.    These are not visible but take effect anyway.    If 
additional paragraphs are selected by the links, their status will show as a colored box without an X -- it may be useful
to scan the section to confirm that system selections/exclusions are appropriate for the project (this is true whether 
you are updating an existing section or preparing a new one).



View Updated Master Paragraph

Use this option to view the changes that will be made if you apply the updates to the current paragraph.    For choices,
only the currently selected choice(s) are displayed.    To see all updated choice options, you must accept the update 
for that paragraph.



Modify Font

The settings for font, font style, size, effects, and color can be changed.    The fonts available are those already 
installed in Windows.

The font can be set differently for each paragraph level of the specification.    Levels 1 and 3 are used for the Title and
body, respectively, of the Table of Contents and Requirements Reports.

Set the font as part of the paragraph format, accessed from the Format Menu, Paragraph Format.



Print Preview

This is the Print Preview window, where the document is displayed showing what it will look like when printed.

To page through the document use the NEXT and PREVIOUS buttons.

To view 2 pages at a time, press the TWO PAGE button.    Then press the ONE PAGE button to restore one page 
view.

To print the currently displayed document(s), press the PRINT button.

To return to the previous window, press the CLOSE button.

To view the document at a larger size, press the ZOOM IN button.



Copy Project From

Select the project file to be copied.

If the correct file is not visible in the window on the left side of the dialog box, change the drive letter and directory 
until the correct file appears.

Use the pull down menu to change the drive letter.

Double-click on the directory to display its subdirectories.    Click on a directory to make it current (if it displays above 
the directory box it is current.)

Double-click on the file name to make it show in the FILE box at the upper left.

Press OK when the correct file is displayed.

NOTE:    If you know the drive, directory path, and file name, you can type it directly into the FILE box.



Copy Project To

Enter a new file name for the new project.    Use any legal file name and the extension .SLP.    (.SLP stands for 
SpecLink Project, and allows the software to identify the file as a project file.)

Verify that the current drive and directory are the correct location for the new project file.    Change them if necessary.

Use the pull down menu to change the drive letter.

Double-click on the directory to display its subdirectories.    Click on a directory to make it current (if it displays above 
the directory box it is current.)

Press OK when the correct directory and file name are displayed.



Detail Links

This is the Detail Links dialog box, where details of links that involve choices are displayed and, if they are project 
links, modified.    The current link for the current paragraph is shown. 

To display other links for this paragraph, use the NEXT and PREVIOUS buttons.    When finished, press the CLOSE 
button.

Click here to explore the dialog box.

Click here for more details on linking.



Move Section

A user-added section can be moved to change its section number.    Master database sections cannot be changed.

To move a section, pull down the Section Menu, select Move Section, and enter the new section number.



Select Section Button

To add a section to the project, press the Select Section button or pull down the Section Menu, select Change Status,
and click Selected.



Permissions

Access to the master database is limited to subscribers, by "catalogs" and by number of concurrent users.    To set up
access, you set permissions at Permissions on the File Menu.

ACCESS ID:    Unique number determined for your current hardware and installation configuration.

ACCESS KEY:    Unique number relayed to you by technical support.    After you enter this number and press TAB, 
your permissions will display.

ALLOW CHANGES:    Check this box if you need to re-enter your ACCESS KEY for any reason.    This prevents 
inadvertent changes.

RENEWAL DATE:    Enter the date your subscription will expire, for future reference.

EFFECTIVE DATES:    The dates the current master is effective for.    After the end date, existing sections may be 
printed and exported only.

AVAILABLE CATALOGS:    Displays those catalogs that permission is provided for.    To display the catalog 
membership of each section, at the Project Window, select the View Menu, Status Columns, and Catalogs.

USER COUNT:    The number of concurrent users allowed.



Rename Project

Prompts for selection of existing project file name and entry of new file name.    Does not change project name and id 
entered under Summary Info.

Access this function from the File menu at the Project Window.



Export Documents

Enter an appropriate file name, directory and path for the exported documents.

NOTE:    Each set of selected documents will be exported into a single file.



Compact Project

The project database can be compacted to save some disk space.    Compacting reorganizes the data for more 
efficient storage but doesn't remove unused items.    However, since the master text is never actually copied into your 
project, it is not necessary to compact the project when sections are deselected.

On the other hand, if user-added sections (which are stored in the project) are deleted compacting might significantly 
reduce the size of a project.    This might be useful if user-added sections have been removed, especially if an office 
master project containing many more user-added sections than are actually needed was used to start the project.



Repair Project

If the software is terminated abnormally, such as when the power fails, a project database could potentially become 
corrupted.    In that case, use Repair Project to repair it.    Since it is almost always necessary to compact the file after 
repairing it, repair automatically compacts it.

If Repair Project is not successful, contact technical support -- however, there may not actually be a way to recover 
the project.

To prevent losses of data, back-up your projects regularly. 



Change to the Edit and Choice Panels

In Version 1.1, the Choice Panel has been eliminated.    Choice selection now occurs directly in the Edit Panel.

In the Edit Panel, the choice options are bracketed and bolded:

[choice text] example

To pull up the Choice List, double-click on the bold text.    Then select the desired choice(s) as before.

To enter a fill-in, type directly into the fill-in space in the Edit Panel:

[[ _______ ]] example

More on choices




